Texture curved surface, has something changed in 2023?


I could not find any post about this topic, so here we go.

In past versions of sketchup, we could paint a curved surface like described in this video (note the timestamp): https://youtu.be/J_inpiCqdkk?t=331

But that seems not to be working anymore. If I apply the texture to a single face, and chose the origin point of the texture.

I then “sample paint” the texture, and paint the rest of the faces like in the video, and it ends up like this:

I have been painting curved surfaces like that for several years now, without this issue, so I am guessing something has changed in version 2023?

I can still paint a curved surface, by not showing hidden geometry, and then apply the texture to the hole curved face at once. The texture is applied seamless. But the problem is here, that I did not chose where the texture origin point was, and that is very important for my use cases.

Does anyone know anything about this? Is it a bug in this version? Can you do this in your version without above issue? Any help is highly appreciated, thanks!


Yes I can confirm it behaves differently in 2023.

I don’t know of any changes in 2023 that would account for this, and I can get the same strange behavior in 2021 and 2022.

While looking into this I did find a way to paint a cylinder without needing to use hidden geometry. It works in 2023 as well as earlier versions.

Rough steps are:

  1. Make a vertical rectangle that is as wide as the diameter of the final cylinder.
  2. Scale the width of the rectangle to 3.1415926.
  3. Import as Texture the image. Place it onto the rectangle so that it starts in the bottom left corner, and exactly fits the width.
  4. Adjust the top edge of the rectangle until it just crops the top of the image.
  5. You could right-click, Make Unique Texture at this point, so that the material matches the geometry.
  6. Make a circle on the ground that has a radius that is half the diameter you used in step 1.
  7. Push Pull the circle to be the height of the rectangle.
  8. Right-click on the face of the rectangle, and in Texture make sure Projected isn’t selected.
  9. Paint Bucket, eyedropper, pick up the rectangle’s material.
  10. Click on the face of the cylinder.



2022, after editing the texture position/scale of the first face and repeating…

Hi Colin

I appreciate the workaround. There must have been some kind of change from 2022 to 2023. I just tried to test my old workflow in version 2022, and it turn out fine as expected:

I did the same test in 2023 + some more, and nothing but one worked. The only one that worked, was a square rounded with FredoCorner plugin (number 3 from the left). Number 4 from the left is a polygon.

I can not use your workaround, sins we have many shapes where the issue persist. So I think for now its easier to open 2022, do our stuff there, and copy it back to 2023…

@Theis maybe this can be a workaround too, if you want to stay in 2023…

@Cotty That’s not working in 2023.

I did a lot of looking into this, before logging a bug about it. I found that the same problem happens in all versions of SketchUp.

There is still a bug to fix, but it’s less urgent as it seems to have always been this way. It seems that if you have adjusted the image at all, say perhaps you have had to flip the image, then the sections don’t line up, even in 2017. If you haven’t adjusted the image, then the sections line up, even in 2023.

The solution is to right-click, Make Unique Texture, after doing any position adjustments. Then use the eyedropper to pick up the new material. That should then fill the faces in correctly.

I’ll just drop this video in to show that with identical geometry and image you get different results in 2022 and 2023. Note the full image in 2022 and the split image in 2023.


Thank you for doing that. Can I try your file?

Imported images default to projected. How do you get them not to be projected right away?

I have noticed textures in 2023 not aligning properly on cubes (like marble for countertops) by default even if i copy the texture from 1 side then pasted to one of the sides and i couldn’t rectify it. It sounds like exactly this issue. It was never an issue on 2022 or prior.

I didn’t save that file, but I can set it up the same and attach it if you want.
All it is is a cylinder and an image.
I have done it twice, set up the same way with different images and it behaved the same both times.

I see the difference between what you are doing and what I was doing. Now I see different behavior in 2022. I still don’t know of any change that we made that would account for this, but I created a bug report for it to be looked into. It’s SKOR-17567 in our system.

Thanks very much. Do you have a public link where we can follow the bug status?

No public link. I will try to let you know when there is progress.

Posting to remember this thread and maybe bump up. Ditto on the texture sampling/painting issue…eyedropper and bucket are broken in my SU23 experience so far.

Hi Colin. Any updates on the topic? im really hoping for a fix on this for the next version of SketchUp

1 Like


Bumping this issue again bc I just recently updated to Version 23.1.318 and the problem persists as described in this post.

SU Version 23.1.318
Macbook Pro 2022
Monterey 12.5

I have a similar problem
When i tried to apply a marble texture to a column.
How can i resolve this?

Share the model file of the column so we can see exactly what your setup is.

Your profile says you are using SketchUp 2018. Is that correct?