Text Tool not placing text

3dtext

#1

I’m using the 3D text tool and am experiencing an issue. I click on the toolbar, type the text and select the font and click paste. When I do that, the text shows for 1 second and then disappears. So the 3D text is being generated, but not being placed.Sketchup Text Tool Bug-small.mov (2.1 MB)Uploading…


[3DTextTool] Boxes for TEXT Height is marked wrong!
#2

does it work in a new model?

BTW: it’s best to add mac to your topic title…


#3

It works in a new model. Sometimes it works if I quit and restart SketchUp, but I’d rather not have to do that every time the text tool stops working.

Thanks for the advice about labelling it a Mac issue.


#4

can you post the skp, as it must have an issue…
john


#5

I would but it’s a huge file (228MB). And it’s not just that file that I’ve had issues in. It’s happened in other files too.


#6

Hi FraserB-

There’s a bug in SketchUp on Mac where the component dialog interferes with the 3d text tool. The 3d text tool will work fine until there’s a selection in the component browser, then text stops working. Unfortunately, just closing the component browser doesn’t fix the issue once you’ve encountered it, you’ll need to close the browser and then restart SketchUp before the 3d text tool returns to normal.

Fixing this bug is very high on our priority list for Mac.

Thanks,
Marc


#7

Hi, I am new to SketchUp Make and am having exactly the same problem as FraserB. I am using windows 8.1. I have tried
Marc’s suggestion of restarting sketchup but that hasn’t worked. It’s frustrating when you can see your text there for a second before it disappears. This was also happening with the dimensions tool but seemed to rectify itself. But not for text. Desperate for solution…assignment due tonight! Thanks in advance.AZ


#8

Thanks Marc. It sounds like I’ll have to quit and reopen until it’s fixed. Not ideal, but great to know there’s a fix coming. I appreciate the feedback.


#9

Hi peterandbiancaf,

Just restarting isn’t enough, to be safe you’ll also need to make sure that the component browser is closed before you restart. Does that help at all?

-Marc


#10

So pleased you’re working on this Marc, I’m rebooting every 15 minutes on my Mac to get the text working …