3D Text is not working

mac

#1

3D Text hangs when selected, can’t do anything else and have to force quit. Seems to only be in files created with previous versions (2017or 2016). Could be related to upgrading macOS to 10.13 from 10.12. If I use 3d text in a new document, SKP hangs trying to open one of the “older” documents. Had luck creating 3D Text, selecting copy, closing SKP, opening the “older” document and pasting the text- super annoying to say the least.

Any hints?

Thanks, Dennis


#2

What version of SketchUp are you using now?


#3

Using 2018.


#4

Does 3D Text work in a new SketchUp file? Your description is difficult to follow.

How large are your older files?

Please finish up your profile with SketchUp version please.


#5

3D Text does work when selecting File> New. It does not work with existing files, all of which I’ve tested were originally created with v2017 or v2016. Currently using v2018. The older files are very large - 500mb+.


#6

Try purging unused and see if you can get the file size down. Maybe you just need to give it more time due to the obese file size.


#7

I purge pretty regularly. These are large files with many imported low res images as textures. I’ve waited as long as a hour as a test, gave up.


#8

Any difference if you change the face style to Hidden Line?


#9

No difference. Also tried the 3D Text tool in similar era files of a similar size and the tool worked fine. Seems to be only on a couple of files.


#10

When you force quit, you’re generating a spin dump. If you could locate those, and look at the first thread’s calls to confirm it’s 3D Text. Or PM them to me.


#11

Barry,
Where would I find the spin dump files?
-Dennis


#12

#13

Sent a PM w/ the crash report.


#14

Yea, and I responded with some ideas. It looks like a memory issue, so I had you try things for less memory footprint.


#15

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.