3D text not loading?

Hi, I have just purchased SU 2018 and having trouble getting fonts I have installed to be findable in the font selection window of SU? (i.e. I can’t use the fonts I need to!).

FYI I have loaded both the TTF and OTP versions with no luck.

HELP!

Hello. Which fonts are you trying to use exactly?

The 3D Text tool only supports TTF (Truetype) fonts. Did you restart SketchUp after installing your fonts? Usually applications do only see fonts that were installed when they were opened.

Did you install SketchUp properly ?

It must be installed using “Run as administrator”.

You can reset it relatively easily…
Close SketchUp.
Find its installer exe file - probably in your Downloads folder.
Select its icon.
Right-click >
Context-menu >
Run as administrator
When prompted choose "Repair"
After it completes restart SketchUp,
Any improvement ?

As has been said only TTF fonts works with 3dText.
There are a very few with loading issues, but 99% seem to work just fine…

Hi,

Thanks for the responses.

The font I am trying to use is a True Type Font, Knockout-HTF46-Flyweight

I wasn’t aware the SU application needs to be installed in the manner described by TIG, however I’ve done as he suggested - no improvement.

This must be an issue with SU2018 as we have used this same font succesfully on two other laptops (i’ve just had a machine upgrade) and they are running SU2016. Looks like it’s best if I downgrade my SU license and re-install it as 2016 and see if that will work.

Any other ideas before I do that?

I don’t think so. I hunted up the TTF version of the font and installed it in the Windows fonts. It seems to work just fine in SketchUp 2018 for me.

Thanks Dave, yep that’s the right font. OK Any other ideas on why it wouldn’t work then?

What if you uninstall the OTF version of the font? Any change?

If that fails and since you didn’t install SketchUp correctly the first time, you might try uninstalling it and install it again correctly.

Hi Dave,

Initially, I installed both the TTF and OTF versions, but neither worked.

I have now uninstalled & re-installed (run as administrator while installing and opening the program for the first time).

Still no change?

Did you uninstall the OTF version of the font?

No, should I have done this first?

I wrote this 15 minutes ago. You haven’t got anything else to try. It can’t hurt to uninstall the OTF version and see what happens.

OK sorry must have missed that.

I have tried uninstalling all Knockout fonts and re-installing just the TTF one, restarted SU. No luck.
Done the same with the OTF font, no luck there either.

?

SketchUp on Windows only uses TTF fonts for 3D Text. You were told that two days ago. Installing the OTF version isn’t going to work.

Have you rebooted the computer after reinstalling SketchUp?

Hi,

The first thing I did was to install the TTF version, that’s shown in my first post.

OK I have re-booted, but still no luck.

Could there be any other setttings (not in SU but perhaps in Windows) that might affect these things?

May be a silly question, but I don’t see it mentioned above. Does the installed TrueType font work in other applications - Word or Libre Office, for example?

1 Like

Hi John,

Not a silly question at all. Yes these fonts (the OTF & TTF) work fine in Adobe Illustrator, In-Design, not to mention the two other computers we are running SU 2016 on (and work fine). For some reason, it’s just this latest version of 2018 that seems to be a problem.

I’ve just arranged to get it downgraded to SU2016 (so all our computers will run the same version). Once I uninstall and reinstall (as SU2016, using the “Run as administrator”) I will let you know how it goes in a few hours.

Thanks for everyone’s help. Still not sure how to fix this issue though.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.