Newly installed font not available for 3D text in SketchUp

I have a client that requires me to use a particular font (the client’s logotype) in a model. I have downloaded and installed the font, and it shows up in menus in other programs. However the font does not show up in the SketchUp fonts dialog for 3D text. I originally installed the font as a .otf, then used a converter to convert it to .ttf, but this did not solve the problem. I also tried creating the text in a graphics program (Affinity Designer) and exporting it both as .dxf and .dwg, but attempts to import these files into SketchUp failed. I’m trying to avoid manually tracing the letters in SketchUp. I really dislike the font, but can’t talk the client out of it.

I am running SketchUp 2024 on a 2020 iMac. The font is Big John pro. Any help?

Did you quit and reopen SketchUp after installing the font?

Please complete and update your forum profile.

I hunted up the font and installed the OTF version and then quit and reopened SketchUp. Big John PRO showed up as expected.

I tried on Mac as well. I happened to have SketchUp closed on one Mac, and open on another. In both cases the font showed up, even without restarting SketchUp.

On Mac that had SketchUp closed:

On Mac that had SketchUp open:

I realized I didn’t say how I installed the fonts. The font is a free one, and comes with these files:


I opened Font Book and dragged the three files in, and chose the Install option. Then went to SketchUp to use them. No converting of the files, or placing them in particular folders on my Mac.

I noticed one thing, that I’m checking into. The three fonts look the same when placed in SketchUp. Not sure yet why that is.

I tried with ThomThom’s editable 3D text extension, and that had the same problem. Next I removed the font and only installed the Light version. Still SketchUp showed the bold version.

I expect it’s due to the way the font is made. Rather common with free fonts.

2D text using that font looks correct. But yes, there is something lacking about the font!

Thank you, thank you!

I guess the problem was with the way I installed the font. Previously I had just dragged it into the fonts folder, Somehow installing it through Font Book made the difference. Oh, and I also restarted the computer before installing the font.

So now it’s solved? Great!

BTW, please update and complete your forum profile with the version of SketchUp you are using and the operating system. Surely you aren’t still using El Capitan.

Didn’t even know I had a profile. It’s been updated, though the photo is a little old.

1 Like

IT’s been a while since you created it so no surprise that it slipped throught the cracks.

I won’t tell anyone about the photo, though. I guess mine is old, too. :wink: