Text format in .csv report file for Len attribute instead of number

pro
generate_report

#1

I just upgraded to 2017 recently and was quite surprised that when reports are generated, all Length attributes now contain either " ’ " or " m " or " mm " for each length unit in .csv file.

When you edit report, no matter what you select as unit format, engineering, decimal or metric, it will add either “m” or “mm” or apostrophe to the length. And now you can’t easily calculate any data in excel, because it doesn’t recognize this as a number. It treats it as text. Looks like you have to manually remove text characters in order to use any formulas.

Anybody know’s what’s up with that and how to fix this?


#3

Yes it is the way the feature is currently written.
(So I’ve moved this into the Feature Request category.)
Others have also complained, and want some control over units format output, usually because they also are using the output in Excel, etc.

The good news is that this is a cloud feature, and updates and fixes need not wait for a normal release (either major, minor or maintenance.)


#4

I found a solution, but it a lot of hassle. Need to re-write entire library of components.
If I add custom attribute with link to Len attribute, and use it as decimal number - it will provide me with the length in decimal inches with up to 8 digits after period.
But here is the huge problem:

In case of changes in dimensions, custom attributes are rewritten only if you manually click “apply”. So, I have to go through hundreds of components in model and update them manually if they were changed. Which is not even an option unless there is a way to update attributes automatically, but I just never learned any good method if there is any.

Another possible way of working around this is to set an excel formula that extract only digit portion from the cell and then format it to a number.

Why would developers do this? What is the reason of changing solution that was working fine for years?


#5

If the old interface still works for you, then to use it, disconnect from the internet and the old “built-in” report generator window will popup.

Sounds like a Ruby script to me.


#6

I tried export with internet disconnected. It works! You saved my day. Thank you!


#7

Hi, if you want to export length and other data to Excel, you could try the SU2XL extension: https://extensions.sketchup.com/en/content/su2xl-0
With it you can select the unit and you get figures (without “mm”, “m” or any other symbol).


#8

Will try, thx.


#9

I now using a simple workaround in Excel => Find " ’ " and replace with " space ". Takes less than 5 seconds to delete all apostrophes and quotes.