Template not updating on Welcome Screen SU2021

Hello,

I really only use one template in SketchUp. I’m noticing the welcome screen still has my older version of it from 2019 and doesn’t seem to update even though I’ve updated the .skp in the Roaming Folder. Is the 2019 file still just in memory and needs to be cleared some way? Any ideas to help with this?

Thank you.

Have you closed SketchUp and restarted it since you updated the template?

I did and then just tried restarting computer to see if that did it and it still is stuck on the 2019 template on the welcome screen.

Interesting. The welcomes screen is basically a webpage. It sounds like yours is stuck reading a cached version. Maybe clearing caches?

Clearing Cache in SketchUp? Do you know where that is located?

Thanks.

The webcache folder is located two levels up from where you found the templates

I see that now. But what do I do exactly? Just blow it out and delete all those files and sketchup will do its thing and repopulate what it needs on next startup?

correct!

That didn’t seem to work either.

There is an entry in of the .json files. I can’t remember where’s what, but they are called PrivatePreference.json and SharedPreferences.json
One is in local, the other in roaming.
Try to look for template folders
(On a phone…)

Check the path of the files in PrivatePreferences.json:

%AppData%/Local/SketchUp/SketchUp 2021/Sketchup

What does it say?

It shows the correct folder. I appreciate your patience and help.

The version that comes up in sketchup is an older version of the template ‘Engineering 10.17.19’

one more place to check:
C:/Program Files/SketchUp/SketchUp 2021/Resources/en-US/Templates

I tried dropping the template in that folder and it didn’t do anything either.

Try repairing the installation. Find the downloaded installer, right click on it, choose Run as administrator, and then, when the option is presented, choose Repair.

Already tried that too. It’s puzzling to me.

Not a huge deal, but it’d be nice to fix if anyone else has ideas to try.

one more thing
(use at own risk)
Type regedit in the Windows search
proceed as admin
search for this entry:
Computer\HKEY_CURRENT_USER\SOFTWARE\SketchUp\SketchUp 2021\Recent File List
or earlier versions, maybe it got copied