Tape measure tool not toggling

I checked my bug report, and it recently was modified so that it would be reviewed again. @MikeTadros will hopefully be involved in the review, and can speak up on behalf of users of the tape measure tool. (bug: SKIT-3976)

Can you describe an action you might need to do, where being stuck in add guide mode would stop you from doing the action?

@colin thanks for the ping. I don’t think there are any further explanations needed here. I’ll see what I can do.

I cannot for the life of me figure out how to get this diagonal measurement with guide mode stuck on.

Tried changing the guide axis with the arrow keys but it always gives me a perpendicular measurement from the point or says “0”.

Would love this to be fixed.

If you want a diagonal measurement, you need to start from a point, not an edge. Starting from an edge will give you a dimension parallel to that edge. The only thing to fix in your case is the way you are using the tool.

Let’s hope it is fixed soon. In the mean time taking measurements is default mode when snapping from a node or endpoint rather than from mid-edge. So a workaround is to draw a short line to place an endpoint where you want to start the measure, then the tape will measure to any point in the model.

It lets me do any measurement I want with guide mode disabled! So you’re saying I need to add a temporary point just to be able to do the measurement? That’s a serious pain. I think “the only thing to fix” here is guide mode being stuck on.

The protractor tool can make those diagonals.

Protractor is telling me angles, not distances.

Me thinks you missed it. Use the line created by the protractor tool to create an intersection on the lines you wish to measure. Then use the tape measure tool to measure between the intersections.

I understood your goal was foremost to create a diagonal construction line.

The issue here, I guess, that the " Ctrl=toggle create guides " does not work in a web version.

In the animation you can see the concentric circles when I press the CTRL button:

Web version does NOT work:
web-toogle-guides

_
Desktop version… the way it should work .:
desktop-toogle-guides

Maybe @colin, @MikeTadros can check why… :wink:

1 Like

My goal was to quickly check the rough distance on the diagonal so I could order the right length of lumber to do cross-bracing.

I appreciate the offers of workarounds, but mainly I’d just like to express my desire to have a fix for the original issue.

Hi everyone, sorry for the radio silence here for a bit. There is indeed a fix underway. Unfortunately, it’s part of a bigger update to the app meaning it’s still a few weeks away. Appreciate your patience as try to squash this issue once and for all.

Just wanted to let everyone now that the issue with toggling guide mode on/off for Tape Measure (and protractor) is now fixed with the latest SketchUp for Web release. Thanks for reporting the issue and your patience while we fixed it!

5 Likes