Tape measure tool not toggling

I’m having an issue with my 2020 web-based sketchup for windows. The tape measure tool comes up when I press ‘t’.
But when I press ‘ctrl’ to toggle off the detail line, nothing happens. Is there a hotkey that disabled the toggle? I don’t think so because I wasn’t having this issue before today when the new sketchup version dropped.

(Update) This is not an isolated issue, I TA for a sketchup course, and and several of the students have this same issue. The professor found a poor workaround that doesn’t work for me. But if you go to set a detail line while holding the arrow key to force it in that direction he can press ‘ctrl’ and move the mouse away from the line and move it back again and that enabled it to toggle.

Apologies for the poor explanation but this is a major issue for me as it turns grading into a massive headache.

I see the same. Keyboard modifier for the tape measure tool appears to be broken.

edit: pinging @colin and @Mark

I also see this problem and am glad to hear it’s not just me. I have seen it on Sketchup Shop on both Linux (Chrome) and Mac (Chrome).

I filed a support ticket and am waiting for a reply.

2 Likes

I pinged my support ticket again today since it’s still broken and I haven’t heard back.

I see your reply, and I’m not sure why my colleague didn’t see your previous reply. I will check with him.

I’m also asking the developers about the issue itself.

1 Like

I didn’t yet get an answer from that team, they were busy posting an update. Unfortunately, as far as I can see the update has the same issue, so I logged a bug report about it.

1 Like

Thanks - is there any way to track that bug report or is it purely internal?

I think that it’s entirely internal. I will get update notices, but a lot of people are already starting a holiday break. It may be some time before it gets attention.

I’m glad to see this is getting some attention from when I initially started the thread. I read that bugs are fixed based on priority. So to help increase the urgency I will add some compelling reasons to resolve this issue post haste.

  1. As previously stated I TA for a class that solely uses SketchUp. I have to use the tape measure tool for grading. Not being able to toggle off the guide drawing tool mean I have to constantly come up with new ways to measure the model as certain starting points will cause the measurement to read 0". This bug has added roughly 50% to the time it takes grade each model. Many models now take me upwards of an hour or more to grade which is a completely unacceptable waste of time.
  2. This issue seems to affect nearly all users
  3. There is not a viable/consistent working solution. The toggle is broken plain and simple.

A quick tip on this. If you use the edge tool you can simply read it real time in the measurement window, and escape or l will drop the edge and leave you with the pencil ready, or ctrl z if you made the second click and want to remove the created edge.

I’m afraid I am not sure what you are referring to, with regards to the edge tool. Is it possible this is an aspect only available with SketchUp Pro? I am only able to use the free version on the web browser and after a quick check, I did not see any edge tool in the SketchUp free.

The line tool, the one that looks like a pencil. It is correctly called an edge tool because it creates an edge rather than draw a line as this is 3d modelling, not drawing.

ah thank you for the clarification.

FWIW, if you are using the Tape Measure tool you can skip the second click and you can hit Esc to stop measuring. In my normal practice I don’t bother toggling guidelines off. I leave it on and just do as I described above.

2 Likes

You are correct, and this is what I normally do now. There are however certain instances where doing this will result in a measurement of 0" as previously described above. Previous to this bug, I could toggle off guides and never deal with this issue. now I have to find different ways to measure objects so as to avoid those certain instances, and it wastes time. I liken it to riding a bike with under-inflated tires. I can still get to where i’m going, it just takes longer and requires more effort than it would if the tires were properly inflated.

1 Like

Yes even using the workaround I hit the 0" failure mode some of the time.

For me, it is also exacerbated by another sketchup web bug: pushing CTRL+Z to undo mucks up the control modifier requiring another tap of control to reset it. Definitely a huge annoyance on top of the underlying bug requiring the constant workaround.

Please, please roll back the breaking change so we can have a tape measure again.

@writeonlymemory and @cli14003 You are hitting the 0" failure as you call it because you have the display precision set to the default 1/16". Open model info at the next to last bottom right icon and change the display precision to 1/64th, also turn off length snapping while you are there. If you need more precision change the display format to 0.0" which will give you 6 decimal places of precision.

The toggle certainly needs to be fixed ASAP.

This is actually not the problem I am describing. The guide tool does not always work like the tape measure does: in some cases it doesn’t measure the right direction/line, which results in it measuring as “0” even though it’s actually a large value. It’s… hard to explain.

Can you show an example of this? Maybe just a screenshot? You should be able to use the edge tool to measure anything in the model also with the settings I outlined.

Clearly this needs to be fixed, I’m just trying to help you get the workaround working for you. Which it should.

@colin Hey, have you heard any updates? This is still broken and still a huge pain.