Tape measure, measurement window bug


#1

Since upgrading to 2018 Pro, I’ve had this issue which is frustrating. When pulling out a guide with the tape measure (to set a precise distance from another line, like 3.5" for a wall), I’ll pull out the guide to a close distance and then try to go to the measurement window to enter the precise measurement. Instead of the “current” measurement in the dialogue box, a seemingly unrelated measurement of area in sq ft appears and then the dialogue box goes blank and I have to type in the full measurement (PITB if it’s a lengthy number and fraction by memory instead of just replacing a fraction denominator for example…).

Anybody else have this issue?


#2

Are you clicking in the Measurements window before entering the value? If so, don’t. Don’t even move the cursor to the Measurements window. Just drag out the guideline, let go of the mouse and type the distance.


#3

No, not clicking before, doing just as you recommended, let go of mouse, type distance, hit enter. In SUP 2017, I was able to drag out a guideline to say, 20’ 5 1/16", when I really want 20’ 5 1/8" and can’t get it to lock in. In 2017, the measurement where I dropped the guide would remain, I could just highlight the 8 and change it to a 16, then hit enter. Now in SUP 2018, the measurement field is blank and I have to type in the entire measurement - which is a lot more keystrokes over the course of a day.


#4

I don’t think it was ever the intent that you would click in the Measurements window to highlight and change a number. Do you you use an extended keyboard?


#5

I’ve not had this issue as I don’t use it that way, but I can confirm that the behaviour has changed between 2017 and 2018. In 2017 you could drag the mouse over the text and change it. I also don’t drag with the tape tool (or any other), I prefer to click once to start then a 2nd click to finish. You can still just type the dimension as before, its the editing of dimensions that has changed. At least with mm anyway, it is much quicker to just type the correct value than to select part of the value with the mouse then correcting it.

He’s not clicking in the measurements window, but dragging the mouse over some of it to select the wrong part then typing the correct value.


#6

If you try to edit that Measurement pane it exits the current tool.
Just type [in open space] the FULL value of the desired dimension and press enter…
Never click on the Measurement pane [ever, ever] :wink:


#7

unless on a mac, like the OP…

john


#8

I don’t usually do it, but you can if you want to. In SU2018 you can still edit the size of e.g. a freshly created rectangle or circle. This is after the 2nd click or you’ve finished the drag operation. You can then drag-select some text like @destratification was doing or even click in the measurements window and edit the size to what you want and it works.

If I was forced to use inches and fractions I’d probably be more inclined to edit it too.


#9

Another poor divergent usage PC v. MAC
SketchUp should work one way OR the other way…
Why make life complicated across platforms ?


#10

McGordon is right on the money with my methods, and good to know behaviour has changed and I’m not just crazy.
I am on a mac, with extended keyboard. In a majority of my work I’m pulling out building dimensions and working with feet, inches and fractions - so typing in these full dimensions is a PITB. I preferred 2017 for just being able to highlight one character to edit…
I’ve been learning on the fly while working over the last year, so maybe it’s time to review some other methods to increase productivity/efficiency.
thanks for all the input.


#11

Hmm. I have done this in the past, but not too often, so I just went and tried it and it worked.

That’s on a Mac, SU Pro 2018 and El Capitan.

Edit: Double checking a fine point here - drag out to approximate amount, and then click to set approximate values. Then you can click into the box and edit the text. This technique of clicking and then entering a value is the only saving grace in SU with a Wacom tablet which I also use.


#12

Like this?


#13

For the rectangle tool, yes it still works in SU2018. The OP was asking about the Tape Measure tool and its behaviour has changed from SU2017 to SU2018.


#14

Ah, sorry, my mistake. I hadn’t noticed until this thread, but I see it here now; The tape measure has changed between 2017 and 2018. It seems weird to me that the tape measure should be different from creating anything else.


#15

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.