Taking slice from solid group ends up with non solid

I have created a solid cone using a circle and follow me arc; when I try to take an off center slice of the cone, I end up with a non solid. I use a separate rectangle that has thickness using push/pull and then move the rectangle through the cone on the green axis. Everything looks good until I intersect the rectangle and cone and remove all the unwanted parts (below the green ‘horizon’). The resulting slice is not solid and has many little triangular ‘holes’ in the side.
Any suggestions as to what I might be doing wrong? Or better way to create the wanted part for 3d printing.

ThanksCameraMount11.skp (2.2 MB)

Without looking at your model I’m going to guess that it is a scale issue.
As soon as you mentioned 3d printing it suggests you are working on something very small.
Have a look here.

Thanks Box
I just tried that and the slice of the cone now looks perfect but it is still not a solid object which I believe I need for 3d printing.

You’ve managed to create a curve that is nearly impossible to slice at that specific point cleanly. The number of segments and the shallowness of the curve makes for some very small edges even when scaled up by 10,000. Sketchup wants to fix two spots that it still thinks are coincident, leaving two tiny missing triangles.
But anyway, here it is having been scaled up by 1000, it works, but don’t let sketchup Repair it. I left the big one in, but you can happily delete it.
CameraMount11Box.skp (336.2 KB)

Thanks Box; I will try to print and see what I get. I may also try to slice a bigger portion of the cone and then see if that works without any missing bits - I can cut the slice along the desired lines after.printing.

It’s not clear to me. Did you want the part of the cone above the cutter, as Box created, or the slice of the cone like this?

The part of the cone above the cutter.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.