Switching from Imperial to Metric

Hi Guys, I have just updated to SU Pro Version 21.0.392
I have selected “Window” then “Model info” and I want to select metric but it doesn’t have this highlighted. I can only select using imperial, feet and inches…

How do I change this please guys…

Use Window Menu → Model Info → Units Select Decimal for Format and then you can choose between mm, cm or m.

Thanks Jean.

Ok, so all of my old files have remained in metric and I can change them from the menu as you have described. But if I highlight part of the drawing then copy and paste this to a new file… I then goto windows menu - Model info - it simply doesn’t highlight metric so I can’t select it? so It stays in imperial?


Your image shows “Architectural”. This choice as well as “Engineering” and “Fractional” apply only to Imperial.

The “Decimal” choice is valid for both Imperial and Metric.

1 Like

The units settings are stored separately in each model and also in your template. If you want to make metric your default, either choose a different standard template or edit and save your own default template. It appears that you are currently using a template that has Architectural units set, so every new file will get that choice.

You may already know this, but to make sure: the units setting just affects how SketchUp displays units and what it assumes you mean if you type a bare number. It does not actually change the size of anything in the model - internally everything always gets converted to inches even when displayed as cm.


Indeed it is Jean… thank you for pointing this out… I must have covid 20, I’ve been using SU since 2003 and its not a function I regularly look for… Thanks again