Surfaces acts weird in Sketchup, can't make intersections (dwg import)

Hi guys
I am new in this community.
I have been using Sketchup for about a month. Most things seems to work fine. But now me and my colleague have run into a weird kind of problem. Maybe there is a simple solution, but I can’t figure out how to solve it.
The thing is. Sometimes we import dwg-files to begin building a model. But a strange thing happens: When i select a part of a plane, then sometimes it selects a much greater area than what i expect. I have attached a picture of what’s going on.
It is difficult to explain, but no matter where I choose to click on the “floor” in the house, it always selects the whole floor. So i am not allowed to just select a part of the floor to for example delete it. If I try to do that, then it selects all of the floor and deletes it.
But as you can see there are some triangular spots where I have been able to select that specific part and then delete it without the rest of the floor gets erased. But only those parts. And that is not sufficient. I need to be able to work with the floor on all parts of it, without having to think about if it selects the areas in a wrong way.

Hope some of you guys know what I am talking about and can tell me how to fix it. I expect that when importing dwg-files it is just pure lines and planes that are possible to work freely with. But something weird happens that seemes to bind some parts together.
It should be possible to divide the floor-plane into smaller pieces by drawing a line or a square and then select that part. But it’s not, soo… yes, looking forward to hearing from you out there.

This sort of thing can happen when the dwg was drawn imprecisely, leaving tiny gaps between edges and possibly edges that aren’t quite coplanar. So, for example, a gap can cause one face to “leak” into another. An edge that isn’t quite in plane will fail to cut a face.

It’s impossible to analyze from just pictures, but if you can upload a sample model or share a link to it, forum members will take a look and give you a definite diagnosis.

Hi slbaumgartner.
Thank you for your reply. That does sound like a reasonable explanation. I will check tomorrow if tha’s the reason. One reason that it might not be the case, is that even when I draw a perfect square on one of the coplanars it still doesn’t allow me to select that part without also selecting the rest.
Also, I am pretty sure that my colleague who has made the dwg file has made it correctly with no “leaking” as he is quite good at this 3D-modeling.

But yes, I will try to check it out, and if it is not solved, I will try to upload the files so that you can see what’s going on and then, hopefully, we can find the reason for it:)
Thank you, I really appreciate your help.

Joakim

what we do see from the pics is that you do not have Layer0 active, recipe for disaster in SketchUp terms, because that would not separate the lines and faces, e.g. they are still connected.
Keep all ‘Raw’ geometry on Layer0, keep this Layer always active (‘radiobutton’ on) Make Groups or Components of ‘things you can built’ as soon as you have drawn it.

Hi guys
Thanks for your feedback.
The problem hasn’t yet been solved.
What i have tried:
I open a new sketchup project. I import a dwg-file. I then mark it all, right click and then “explode”. I then move all material to Layer0 and deletes the rest of the empty layers.
I then see if the material (lines) are free to use. But still, they seem to be bound together in weird ways. I have attached a few new fotos that shows the problem…
Hope you guys have any ideas how i can make the line material from the dwg file free to use.

I have here attached 8 pictures that shows the proces and the problem.
1: dwg import
2: Selecting all and clicking "explode"
3: assigning all material to layer0
4: deleting the empty layers
5: choosing to move potential content to layer0
6: all material is ungrouped (exploded) and now on layer 0
Now the problem:
7: I draw a square somewhere on the material
8: The selection then “marks” a somewhat random part of the selection, instead of just making the square i made.

What is going on? … :slight_smile:

You need to read about what layers do in SketchUp. They don’t separate geometry. Their only purpose is to controle what should be visible at a certain time, say in a saved scene.

  • Grouped geometry (a group or a component) is separated from the rest of the model content.
  • Active layers are visible / inactive layers are not.
  • Layers are assigned to geometry (only assign a layer other than Layer0) to groups or components, not to basic (raw) geometry. You don’t assign (put on) geometry on a layer.
  • touching geometry (thus being in the same context, say in the same group) is sticky.
  • seemingly touching groups and/or components do not stick together.

There may be something else causing your selection problem after importing the dwg, other than what has been mentioned above. Share the model if allowed.

Simple example of unexpected face:

  • draw a rectangle
  • create a coplanar shape (say a triangle) on the rectangular face. Triangle and rectangle should have only one common corner vertex
  • try to select only the face outside the triangle.
1 Like

Hi Wo3Dan
Thank you for your reply.
I will try to dive a little more into your comments next time I am looking at the model.
I think now I might be able to solve the problem.
If not, I will see if I can get permission to upload the file so you can have a closer look at the model.
Thank you again.

Joakim

Hi again Wo3Dan
I have now been working some more with SketchUp. I am getting better at it.
I now make all my geomtry as Components and only have the dwg-lines on the Layer0.
But: … Maybe there is something about Components that I dont quite get yet.
Because when I close the program and some days later open it again to continue working on the model, the Components doesn’t seem to act as components anymore. They dont seem as flexible.
What is going i wrong here? When I click on a component it seems to only select the part of the geometry that I click on. So the whole point and all my effort in order do build the model out of components seem to have been lost when I close SketchUp.
Hope this makes sense to you and that you maybe have and idea about what I can/should do in order to have a smooth workflow with building models.