My imported CAD file doesn't join with the ground plane properly

Can someone please help. When I imported this CAD file and exploded it- it seems to merge with the ground plane (square) when I placed it, but then when I click on an an area- for example this curb/median, it still selects the entire box, rather than just selecting the area. Is there a way to join these all together? I want to be able to push and pull the sidewalks, roads, etc. Thanks in advance for any help!

Upload the SKP file so we can see what you’ve got. Could be any of several things.

ok, just need to edit it first for copyright contract reasons!

Hi Dave,
it’s taking some time and all of a sudden my SU froze. I’m working on uploading it- but what could be some of the causes?

Try this: draw a line over an existing one

Thanks so much Mihai, I did try that but it wouldn’t work for this case! So frustrating.
I even tried tracing around the building with new lines.

Do DWG CAD files never import flat? Or is there a step I need to take to make the lines join?

Verify something: see if all the lines are in the same plane

Or try with Select everthing > Intesect Faces > With selection.

ok, so interesting! Did not know how to do that- will check. Update- once I added all the layers to the default layer and deleted other layers, when I drew a line (like your first example), it did work!

still doesn’t work for some lines- what if they aren’t on the same plane? what can I do?

First check if they are not in the same plane, then, if necessary, put all the lines in the same plane.

great- how do I pull them to the same plane? I’m pretty sure that’s the problem

You can open the dwg file in DraftSight or Autocad and bring all lines in the same plane (elevation 0);
In Draftsight, change the Z value, or in Autocad use the “Flatten” command.

Or in SketchUp, use the Move tool on Z axis and move the lines to plane 0.

2 Likes

is there a way to just select everything and put it all on the same layer in Sketchup? I’m having trouble “flattening” in autocad- not sure how to do that

As I’ve already written to you, use the “Flatten” command in the Autocad.


See in details: How to flatten a drawing in AutoCAD and AutoCAD LT | AutoCAD | Autodesk Knowledge Network

1 Like

In SketchUp, you could use JHS Power Bar > Center on blue

1 Like

Off Plane is one thing and it is not uncommon with CAD files. I see it quite frequently in files I get from others. I don’t know if it’s sloppy work or something else they are doing or not doing. If you are checking for flat, set units to millimeters and precision as high as it will go. It doesn’t take much off plane to cause this problem and you aren’t likely to see it with coarser units or low precision. Also check the endpoints around the oval to make sure their Z values are the same.

Another common problem is gaps in the loops of edges. Tiny gaps can be difficult to see unless you zoom in closely.

A thrid thing that can cause this is overruns where one edge runs past another.

An easy way to determine if it’s one of these two things is to weld the edges of the over and see if the entire loop gets welded. Use TIG Weld, Eneroth Auto Weld or Weld from FredoTools.

And one more thing that comes to mind. Is the loop of edges grouped or a component?

it’s not a group or component- not sure what looped is but it seems to be all connected. Thnks

A closed loop of edges is required to get a face or to break a larger face into multiple surfaces.

1 Like

I’ve given you the common reasons for the problem you’re seeing. Without being able to see the file there’s not much else to say. We’re only able to guess.

1 Like