Lines don't line up properly

I worked on my project on Autocad and when i tried to import it to Sketch-up some of the lines didnt lined up , on Autocad the lines are lined up together and connected to the right places .
thank you in advance , Dana .

Without the DWG/DXF who can tell ?
Perhaps the lines arenโ€™t โ€˜flatโ€™ ?
If you change your SKPโ€™s View to Plan with Perspective OFF what do you see ??

Did you import it at the same units settings between CAD & SKP ?
Sometimes tiny geometry causes issuesโ€ฆ

Did you use Millimeters as the import unit instead of Meters?(Options button on the Import File dialog box)

what do you mean by Lines arent flat ?
Even when i change the Prespective off it still looks like this .
On Autocad i am working on a unitless , and On Sketchup i am working on Centimeters.

I Enterd this option Button and chose Centimeter and its still crooked .

Upload the CAD file here to get a meaningful answer. Without that, everyone is just guessing.

sketch up ready.dwg (199.8 KB)

thank you

It is not flat. This is how the DWG looks in DWG TrueView when viewed from the front

so how can i fix it?

Use the Flatten command in AutoCad.
Or, in SketchUp, select the Topview, set your camera to Parallel Projection, export a 2D DWG and re-import that.
The non-flat lines are in the room near the main stairs
image image
Note too that the two floor planes are not at the same elevation.

3 Likes

thank you so much!!! it worked!!