Surface creating problem by using lines

Hi dears,

I’m new to this forum, so if this post is off-topic and any other topic can help, please let me know.
I import my Auto-cad file in Sketchup and try to make surface by line tool, my walls are already jointed in Auto-cad while in Skaetchup are not joint and when I try to make surface it will not work properly and just part of surface will be available. I’ll be appreciated if you can help me,
My Auto-cad file and one snap shot are attached.
Thanks in advance

home plan 04.dwg (38.3 KB)

It appears you have layers that overlap your wall layers but are not showing as they are turned off in your layers panel. If you don’t need those layers in SketchUp, either remove them in CAD prior to importing into SketchUp or delete them in SketchUp and try again to make your faces.

Thanks for your reply,
I already need most of them, just hidden to work on my walls :slight_smile:

If you group different linework (layers) first, they will not ‘stick’ to your wall linework and make it easier to make faces.

I had no issue with other layers such as doors and windows, this issue just appeared for wall surface :frowning:

Bringing in a dwg file, I usually group all by the layer then I go into the group and make sure the contents are on Layer0. Then I put the different imported groups on their own layer, if they did not come that way. The doors and windows probably don’t cause an issue either because they are already grouped or because the edges therein just don’t overlap the wall edges. I make the layers visible one at a time group the contents and then when editing the wall group, the pillars are not interfering with wall face formation.

I should add. Might help to first turn on all layers (visible) and inspect the import how it is grouped into components or not, what layer elements are on to help figure out how to separate it into usable parts.

1 Like

Thanks so much, it works and my problem resolved,

There is also a tiny gap at one corner that will cause certain faces not to form until you close it:


Edit: the extra edges in my animation are ones I added while tracking down why a face wouldn’t form for that wall. The usual test is to draw an edge across a region and see where faces do or not form, then try again until you pin it down to a specific small region that you can zoom in to examine.

1 Like

Thank so much, I found it as well,