Hi there.

I have tried to download the Datasmith Exporter plugin from Epic Games/Twinmotion and get stuck at the programme install - see error message here

It’s strange really, the programme download exe file is ‘UnrealDatasmithSketchUpExporter_5_2_1.msi’ but its looking for ‘UnrealDatasmithSketchUpExporter_4_27.msi’

Anyone have any ideas? Thanks.

It could be an error with the installer itself - perhaps reach out to unreal support.

Have you had a previous version installed, as per the instructions , you need to remove that first.

1 Like

Please don’t shout.

Hi Adam. Yes, checked previous versions so will seek advice from Unreal now.


at who, Box?

I went back into my programmes and found the previous older installation still on there even though it was removed - it wont let me remove it at all now.

I did a search for the folder to remove the install from there but its not coming up.

Ok, so that looks like the kind of error you would get if you deleted it without uninstalling it.

Try this windows troubleshooter

That will hopefully be able to remove the memory of it

I had the same problem.

The solution to this is to remove the previous version of Twinmotion Datasmith before installing the new version.

If you already tried to install the new version, then this won’t work.

You have to download the version you had on your computer originally (the error message contains the version number), then right-click and repair this version. After this, I was able to remove it through Windows Setting/ Add or Remove Programs.

After this, you can install the new version.

I finally managed to install Twinmotion and Datasmith for SketchUp, but my computer started overheating with fans running loud from the minute I opened it. So I haven’t gotten very far in experimenting with it just yet. There was another person with the same video card NVIDIA RTX 3080 complaining about the same issue…

1 Like