Subscription Server Response

When attempting to start Sketchup Pro 2020 I get this Message:

“The Subscription Server Response is invalid
You can continue to use sketchup, but will not be allowed to start a new file or open an existing file.”

image

Obviously I am out of business.
Hereis what I have done:
Checked my subscription on Trimble.com It is active, I paid early this year.
Downloaded and ran the installer 2020.1 chose REPAIR, it ran and finished with no apparent problems.
Downloaded and Ran CHECKER. Again all checks returned Success.

I need assistance please. I depend on Sketchup for my design work. Thank You

Have you tried signing out and signing in again? With the subscription license you need to sign in every 28 days.

Where do I sign out? I cannot start Sketchup.

Do you get the welcome screen when you try to start SketchUp?

Did you install SketchUp 2020 by right clicking on the downloaded installer and selecting Run as administrator?

I think there’s something wrong somewhere, I encountered this a short while ago.
Went to help>manage license and that seemed to fix things.
Now if I go there the window stops responding.

Shep

I cannot start Sketchup No welcome screen

When I login at Trimble.com I get a error msg. However it shows my info in the upper right corner. Seems as I am logged in.
Error Msgimage

I will rerun installer as admin right away

1 Like

In case you don’t have the latest version of the installer, get it from sketchup.com/download/all

If going to Trimble Connect in your browser gets you that message, though, it may not be a SketchUp install problem. More likely you need to clear internet file caches. It won’t hurt to repair the installation though, especially if you didn’t use Run as administrator from the context menu when installing it the first time.

Reran Installer. Now it works…seems ok. I can open files.

I will go and try to figure out clear browser cookies

Thanks everyone for your help. DaveR a special thanks for the detailed steps.

1 Like

Cleared all Browser cookies

Does it seem to be working as expected now?

Did you download a fresh copy of the installer? Did you get the option to Repair the installation or did it just install?