SU2020.2 takes 15 minutes to load

HI all,

Noob here hoping to get expert advise. I had installed a SU2020.2 on a W7 pc with 32GB ram, Nvidia P2000 (5GB ) graphics card and 512 SSD drive. Apparently, it takes 15 mins before I get to see the splash screen.

I ran the task mgr and notice 2 program running : Sketchup.exe and sketchup_webhelper.exe running but no activity. I also updated the latest display driver on my pc. I even updated my windows update to the latest.

Any advise is appreciated.


try to repair the installation. First, make sure every SketchUp related process has ended. (Do a cold ‘reboot’)
Then rightclick on the downloaded installer file and choose ‘run as administrator’

HI Mike,

Thank you for the advise. I have removed and reinstalled the program as administrator.

Is there any settings in SU I can reset it to factory default or something. Or to do a cleanup of the cache/ temps it might have accumulated ?


Are you opening SketchUp on its own, or by opening a file? When you get to the welcome screen, does it then seem to work ok?

Hi Colin, I am opening SU on its own and it takes 15 mins without any errors whatsoever.

Any thoughts?


Do you have a driver updater running on your system, there is a microsoft one that I can’t remember the name of that wreaked havoc on one of my old Win7 machines. I removed it and everything started working properly.

Hi Box,

There is no pending updates as I checked around the pc. There is this file PrivatePreference.json file in the Local folder of the user’s profile. I was wondering if I delete this file will help to reset SU to default settings?


How many extensions (a.k.a. plugins) do you have installed? The more you have the longer SketchUp takes to load to the point where you can use it. Having said that, I have quite a few and my SU2020.2 doesn’t take 15 minutes to load.

Hi Julian_Smith,

Thanks for your input. I have installed quite a number of plugins since the day I started using su2020 and am unsure whether it was one of the plugins that caused the lag. I was thinking to reset to default settings and start all over again. Any suggestions how to do it?


Renaming the plugins folder would be a quick way to test if that’s the problem.

There is more than more place that plugins might be, but most would be here:

%AppData%\SketchUp\SketchUp 2018\SketchUp\

You can copy and paste that text into File Explorer to get to the right place. Rename Plugins to anything else, then reopen SketchUp.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.