SU17: "unable to read extension archive"


#1

Upon starting SketchUp pro 2017 I get a popup “there are two extensions ready to be updated”. Its about Artisan and ProfileBuilder2. When using the update button in the extension manager, for both it fails with message: “unable to read extension archive”

Could this be a user-account thing? (bought with one account, currently using another)
I de-installed but then in the EW they both are not flagged anymore as extensions that I have purchased already.
Any suggestions?


#2

You saw two things. When you got the pop up you must have been signed in under the email account you bought the program. When getting that error message about not reading the extension archive, just logout and log back in to reset the connection to the Extension Warehouse server.

At this time, people cannot switch email addresses as that identifier ties them to SU account. For security reasons, the SU team have not (at least yet) implemented this ability.


#3

I’m having the same problem with the change over to Sketchup Pro 2017 with multiple extensions (including ProfileBuilder2). I’m signed into Extension Warehouse with the same username and password that I’ve always used yet when I attempt to update I receive the same “unable to read extension archive” message.


#4

If you are a WIN users…
Did you install SketchUp 2017 by selecting the installer’s exe file and right-click > context-menu > “Run as administrator” ?
If you did not then various unpredictable flakiness occurs…
Simply being an admin or having admin-powers is not sufficient - you must do it this correct way.

You will probably not have to totally uninstall, instead, find the exe file [probably in your Downloads folder ?] and re-run it as administrator - when prompted choose to “Repair”.
When it’s completed try SketchUp again…


#5

Ludwiggv,
In SketchUp log out of all connections (the face icon in the lower left of the main screen), and then close SketchUp. Start up the program again, and then log into Extension Warehouse again before opening the Extension Manager.

Best Regards,
Nick


#6

Thanks Nick. Did exactly as you suggested and still have the same problem. Any other thoughts?

George


#7

Also tried TIG’s suggestion without positive outcome.

Thanks,

George


#8

You could try a full uninstall, followed by a re-installation ‘as administrator’…
Failing another solution, it’ll do no harm…


#9

Thanks again TIG - still no luck. Same problem as before. It may be a problem with ProfileBuilder. I may have to uninstall and try a reinstall.

George


#10

I had this problem with SimLab IGES importer. I logged out of Sketchup 17, then logged back in. I opened the internet browser and logged into the Extension Warehouse. Then when I tried to update the extension it worked. Thanks to all of you who posted to help with this problem.


#11

Again facing this problem. Notified there’s an update - again the ‘unable to read extension archive’ error for PB2.
I blame myself for having three accounts that I used to buy/install plugins during the last 6 years. Just wishing I could migrate all of them into 1 account at some time…


#12

Use the log out and log in icon from within sketchup to refresh your settings. Bottom left corner.


#13

@Box already tried that - even closed SketchUp and re-logged in. Still doesn’t work. Works for all plugins just not for PB2. Will investigate more when I have the time. Just wishing at some point I can migrate my accounts into 1.


#14

Not your fault - Trimble has a painfully fragmented licensing regime for Sketchup Extensions - thoroughly confusing!

Is an extension licensed to the my company who bought the software, the staff user who logged into SU or the machine it is installed on? A mess!

I have 3 licenses of SKALP and PB2 , given up on trying to get PB2 to work … and now avoiding any paid extensions as managing the licenses is a PITA. going back to the KISS principle of Nick Sonder…


#15

Sorry about this. This document shows the fix, and I tested it with a half dozen people to confirm that it works every time:


Failed to update Trimble connect
#16

Thank you, this worked with all the extension updates but one, the Trimble Connect still has the same issue.


#17

Worked Great! Thanks !


#18

That worked for me. Thanks very much :slight_smile:


#19

Did you try this? https://docs.google.com/document/d/1lxsloXP1cpuYKBO1JgdSOphqLxUxzwBHH9rQZMio25M/edit?usp=sharing


#20

Thanks for that!