Update Extension Errors with Extension Manager

Why do i see every time when i start up Sketchup the message there are 4 extensions to
update.
When i accept it its looking on an part of my HDD. Why there?

I see that too, and if I try to update the extensions I get an error about being unable to read the extension archive.

It seems to be a 403 error when the update is being read, possibly because the URL is http. There is a way to work around the issue, by loading the URL in a browser. This for example:

http://extensions.sketchup.com/en/system/files/su_advancedcameratools_3.rbz

Then install that as an extension with Extension Manager. That would reduce the number that need updating to 3.

I’ll either find out what needs to be done to fix the web site, or I will give you a list of four URLs to download.

I thought of another work around. If you use Extension Warehouse and search for the extensions that need updating, and install from there, it gets the update ok. Also found that just installing the dynamic components extension was enough to fix two other extensions, and so now I get no errors when opening SketchUp 2017.

1 Like

Colin,

Can you give me the URL’s for the downloads?

Eric

70101_2.png

You mean like this? I’ve been getting this for a while now.

Is the work around to hit “Uninstall” and then go find it again in Extension Warehouse and install it again? It would be nice if it just worked as you would expect it to.

I get every time this kind of message.

4ebd92a837244c2e24f969eb7d82d8d7187b46f3 2 690x183[1].png

38611 2[1].jpg

your screenshot indicates that you are not ‘logged in’, have you tried when you are?

log_%20in

john

Unfortunately, after testing the download from the warehouse solution I fixed the problem for myself, and so can’t make it go wrong, to then give you URLs.

If John’s suggestion of signing in doesn’t solve things, you could just reinstall one of the extensions. For me that was enough to fix the other ones too, though it could be that I wasn’t signed in on the first tests.

I went over this with some engineers yesterday, and it could be that because 2018 and earlier use http and not https that causes the problem. But I’m now wondering about whether I just wasn’t signed in at the time. Normally when you try to update extensions you are asked to sign in, and back with 2017 maybe it didn’t do that.

In any case, 2017 and 2018 are unlikely to get patches for any issue at all, let along one that has an easy workaround. But, while doing updates to the Extension Warehouse itself, they will make sure to test with 2017, and could possibly fix the issue for everyone without having to update SketchUp 2017 or 2018.

May not be the exact issue, but…


If I am notified that one of my 'shipped_extensions' needs updating, I have found that the Extension Manager lets me do that... Then everything is reported as up to date. However, after I restart the notification repeats...

This is because the Extension Manager updates the files in the Plugins folder, but when SketchUp restarts it copies its shipped_extensions files into the Plugins folder.
Then this overwrites the newer versions - with the older versions !


To avoid this... I do the notified update, then I close SketchUp, then I copy all shipped_extensions [including their subfolders] from the SketchUp Plugins folder back into the shipped_extensions folder. Now when I restart SketchUp the latest versions are found and there are no notifications. Of course, if I ever have to reinstall that SketchUp version, before I ever run it I ensure that the up to date shipped_extensions versions are used to overwrite the older ones in the installed set up...

After I had fixed my extensions, but wanted to repeat my tests, I deleted the four shipped plugins and restarted SketchUp, in the hope of then getting the older shipped ones, that would then need updating. But they didn’t ask to be updated. The plugins in the ShippedExtensions folder are dated September 19th 2017, same as the ones I updated to.

The loader RB files might not have been changed but the contents of their subfolders might have ?

The folders showed today’s date, but the files inside were the same old date.

When i logged in am not getting an message about updates.

45[2].png

log_ in.png