Extension update

The new Extension Manager in SU17 is a great new feature. However, I keep being told there is an extension that has an update ready but when I try to update it, it tells me it can’t (TT_Lib2). What is going on?

try removing the extension and reinstalling the extension

1 Like

Yup, that did it. Thanks!

I have the same problem.
It’s been a while since I installed an extension and I don’t think I ever removed one. How do I do that?

Look in the Extension Manager, at the top, choose Manage, scroll down to the extension (-s) you wish to uninstall, select uninstall. It is probably best to close SketchUp and restart it, just to make sure the current session has been cleared of remnants of the extension that was loaded previously.

Most likely signing out and then back in with the Sig In button in the lower left of the main Sketchup window would have taken care of it.

I have attempted to update extensions without success. When I get notification of updates available I go to Extension Manager and expect to use the update button adjacent to the extension title. It always shows the circle/slash forbidden sign. Then I download the latest version from the extension warehouse. After the successful download I click the “Install Extension” button in the extension manager window and then choose the downloaded file. Nothing happens. The installed extension still has the old date. What am I missing? Appreciate any help.

If an update is available, the button should be red (active), otherwise it is gray and the mouse cursor changes to “not allowed”. Is this the case? What you are describing sounds like you try clicking a button that is disabled (gray, or is it incorrectly red but “not allowed”?).

  • If updating the extension (even manually from a downloaded .rbz) fails, have you tried first uninstalling it?

  • Can you tell which extension it is?

Thanks for your reply. Notifications of updates shows periodically when I first start Sketchup 2017. The latest are Fred06 LibFredo6 and Fredo6 jointPushPull. Extension Manager, I don’t believe, has ever shown a red update button. When I place the cursor on the “Update” button I get the “Not allowed” symbol. I always have had to download the updates manually. In the past I’ve been able to install those downloaded extensions by clicking the red “Install Extension” button in the lower left hand corner of the Extension Manager window. Current attempts to do that have failed to get the extension installed. I have not tried to uninstall and install. I will try that.

I have noticed some oddities when updating extensions myself. Sometimes you are invited to update, you click the button, and then you get told it cannot be updated. No reason given, just goodbye and thanks for all the fish (Hitchiker’s Guide ref!).

Signing out and back in didn’t fix the problem for me.

It did work to select update from the extension ware house rather than the extension manager. Is this a bug?

@Neil_Burkholder I must try this myself. I just fired up SU and was told there were 5 extensions needing updating. Extension Manager was unable to update any of them. I got exactly the same response as you did. Got to be something wrong with the way the system is working. I have successfully used EM to update add-ons in the past but mostly it fails.

This is extremely annoying.

I just had the message that three plugins needed to be updated. Two of them updated fine. It seems Trimble Connect is the big problem. Neither disabling nor uninstalling made the warning go away. Only updating from the extension warehouse is effective.

Does this also apply when one gets a failure to update license error? I got this for 3 extensions just now while trying to update them, after I logged into SU with my Google account.

Me too.

From within SketchUp: log out of your EW account, close SU, open SU again.
From within SU: log back into your EW account, try updating now.

Done that. Looks like everything has automatically updated. So maybe that’s a workaround but it’s surely meant to work without having to do all that, isn’t it?

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.