Problem with Extension manager

After I start SU 2021, latest version, in English, on Mac OS Catalina in French canadian, I receive a message that there are 7 extensions that need to be updated and offered a button to open the Extension manager, which I click.

I am presented with the list of my extensions but I see that there are 28 that need updates and, when I pass the cursor over anyone, I see a circle with a slash telling me that I cannot do that.

I disconnected from SU then reconnected.

I restarted the computer and got the same. I tried the former disconnect/reconnect procedure. No success.

Finally, I tried the sequence : disconnect / restart computer / reconnect. No success.

Everything was working nicely before today on the same computer with SU and OS as described above. I did nothing to my system.

I wonder what might be going on.

No one answered that so I am answering myself to bump it near the top of the list.

I must add that I updated LibFredo6 before this happened.

Is it related ?

I don’t think the LibFredo6 update would be the reason. If you see updates in the Manage tab of Extension Manager, what does the Update button look like?

I though also that it should not be the update to LibFredo6 that was the cause since I have already updated this extensions a few times already without problems.

The majority of the Update buttons look is Light Blue text on a light blue/grey backgound. These are not clickable (greyed out with a slashed circle showing when I pass the cursor over them.

A few buttons are clickable with white text on dark blue background.

Maybe I should reinstall SU from Scratch. I hope I will not loose all the plugins if I do that.

The no entry sign buttons are ones that don’t currently have an update. The white text dark blue ones do have an update. Could that be the only confusing thing, that it looks as if all of the extensions have an update? Does clicking on the ones that work actually update that extension?

If you do replace Applications/SketchUp 2021, your plugins will still be there afterwards.

on bootcamp windows 10, I also got an update notification.
Bezier tools by SketchUp Team.
Tried to update in Extension Manager, got the useless message (ignore/open) but a fail message in the extension manager panel itself.(extension warehouse icon still showing the update arrows)

After redownloading via the extension warehouse and restarting, the update message was gone and also the update arrows on the icon. (all of these in the large toolbar)

but now I cannot uninstall it anymore:

The Bezier tool seems to be the only extension I have installed that has an invalid signature

I’ve been seeing this for a week or two. This is on Windows.

OK, all extensions were updated.

I misunderstood the meaning of the buttons.

This can probably be called a Duh or a Doh moment :face_with_raised_eyebrow:

The Bezier Tools caused no problem.

Thanks everyone.