Fredo6 Extension plug not updating properly


So I’m having problems where my Fredo6 is not updating properly.
I’ve updated my plugins before; especially the Fredo6 on SketchUcation, which I am a member of.

  1. I’ve followed the new version of Fredo6 on Sketchucation and nothing has worked.

  2. I tried to do INSTALL and THEN UPDATE the version of fredo6 by going on “Windows - extensions -fredo6” - but guess what… :0 on my WINDOWS TAB the tab “EXTENTION” is not there :/. SO I can’t update or install anything that way.

  3. I have got the latest Sketchup version, which is 2023. So I tried again by doing:

        A. Extensions - Extension Manager - Fredo6 LibFredo6 
        B. *clicks* the blue button of "INSTALL EXTENSION" - LOCATES and SELECTS the extension plug that I need, which is "LibFredo6_v13.9a.rbz" 
       C. I then click the fredo6 tab WITHIN the extension manager tab - disable it - THEN AGAIN - REPEATS STEP B. 
      D. Press "Apply changes" and then closes the WHOLE APPLICATION for 2 mins before opening it again. 

To my suprise I see my new fredo6 extensions - I click on it and pops up saying I need to update it. :confused:

I’ve been repeating steps A, B AND D and then sometimes steps A,B,C D and nothing works.
Anndddd also repeated this person’s steps: LibFredo6 | SketchUcation


  • as you can see, everything is updated but still cannot use fredo6.

So yeah. Any ideas please?


If I recall well, the extension menu is not visible unless you actually installed one.
also, fredo6’s extensions need sketchup to be restarted so its menu or toolbars can load.

I seemed to fail updating FredoLib today as well. In the end I removed the extension then added it back again.

@Fredo6 may know if there is an updating issue at the moment.

Paul, since 2022 there is an Extensions menu even if you have no extensions installed.

1 Like

I need first to understand what does not work.

The first thing is to check if the menu entries are there in menu Tools > Fredo6 Collection.

In SU2023, I noticed that an extension can be loaded properly but its toolbar would not appear unless you make it visible in the Toolbar Manager. This is a different behavior versus SU2022 and prior versions.

Yes, step D, was me installing, updating and then finally restarting Sketchup to refresh and configure the plug-ins. Still not working I’m afraid.

Dear Fredo6,

Heeyy :D.

First things first. I have re-downloaded, installed, restarted Sketchup and followed too many youtube videos on how to figure out why the Fredo6 plug-in won’t update. Surprisingly in the above picture, it showcases that all plug-ins have been updated but still, I press the plug-in to use on my design and a pop-up exclaiming that I need to update this plug-in still appears. :confused: Yikes.

Secondly, to answer your first question, in the picture that I’ve added to this response, I followed your instructions and to my surprise, the “extensions” tab in the toolbar tab is not there at alllllll :confused: - double yikes.

Thirdly and lastly, yes in the Tools menu, I can see the Fredo6 Collection, but I still get a pop-up alerting me to update my plug-in. So crazy that the plug-in is the newest version (details listed above) from SketchUcation and have repeated all of the steps that I have listed above and still no improvement.

Any thoughts or ideas on how to tackle this?

kind regards

No extensions tab in tools

First, could you show me the ‘popup’ asking you to update.

Second, lets proceed with one plugin at a time. Apparently, you have the toolbar for RoundCorner showing in the Toolbar Manager. Does RoundCorner works?

Third, open the Ruby Console and leave it open while you play with my plugins. There may be useful error messages there. Possibly, leave the Ruby Console open, close Sketchup and restart Sketchup. The Ruby console will display and show error messages at startup which may be related to my plugins.

^ above is the pop when I click on the Fredo rounded corner.

No the round corner does not operate at all; resulting from the warning pop-up.

I’ve never used ruby before so I used this link to strim-read the instructions: Ruby 101 - Lesson 2: Hello World
Unfortunately, I tried many different plug-ins and it was not satisfactory at all.

Any other ideas?

Round Corner and FredoCorner are two different extensions and require different licenses. Make sure you are using the correct one.

My Plugins have a commercial license after a 30 days free-trial period.

Did you purchase the license?

Ahhhh, I see.

Yes will be looking into that right now.

Thanks for your help.