Failed to update plugin

What does it mean when I try to update a plugin and I get a message that SU was unable to read extension archive? Another plugin did update, but not this one:

I have same error and did not find a solution

Close the Extension Manager window. Sign out by clicking the head icon in the lower left corner of the main SketchUp screen. Click it again and sign in. Then go back to the Extension Manager and update the extensions.

The server drops logins after a period of time. Otherwise there’d be millions of users, mostly inactive, logged into the system all the time.


That didn’t work, even after I signed back in.
Also remember I WAS able to update another plug-in besides this one, not just once, but twice over the last few days. It’s just this one that’s giving me trouble. Thanks.

AFAIK you don’t use this one. You could leave it and ignore the update message.

Same here.

Two things that did work.

  1. Uninstall and then reinstall.
  2. Update from the extension warehouse rather than the extension manager.

I did that for a while till the messages got the best of me. :wink: It seems clicking ignore only made the notification disappear. On opening SketchUp again the reminder would still come back.

I just started getting this same situation. Have not seen this in the past. Getting to be a pain. :unamused:

It happened to me this morning and I did as I described, logging out and then logging back in. The updated copy of the extension installed just fine.

Also, like myself, one may have used different accounts to buy/ install extensions, which makes it more confusing…
I also use different accounts to sign in, sometimes to get appropiate credits for the model, but it would be convenient ro enter the extension warehouse with the same account as the one you have been signed in

1 Like

Ah, I had to install it from the extension warehouse to get past that message. Thanks.

Even resetting my PW on my Trimble Account (there are 2??) did not work, nor did logging in with my email account instead.

As John said, I’m not sure I even need this since I work with him and we pass files via dropbox, not over Trimble Connect.

None of the above worked for me, I still get the annoying message.
Downloading from the extension warehouse just gives me a su_trimble_connect_29.rbz, what do I do with that?

Go to the Extension Manager and click on Install Extension. Navigate to the file you downloaded and select it. Click Open, Yes, etc.

I went into Extension Manager and uninstalled all 3 of the extensions it says are out of date. Then I restarted SketchUp and still get the annoying message about the 3 extensions.

Trimble Connect, Advanced Camera Tools, and Sandbocx Tools are the ones that need updating, correct? Uninstalling them doesn’t get rid of them entirely because they are part of the SketchUp package. If you’ve removed them from the User/App Data/…/Plugins folder, SketchUp will reinstall them the next time it starts up.

If you can’t get the extensions to update in the Extension Manager, download them directly from the Extension Warehouse and use Install Extension to install the updated versions. Or just ignore the little pop up message. If you don’t use them anyway, there’s no need to get worried about updating them.

Thanks DaveR - I finally got all 3 to update…

Instead of suing the Manager tab to uninstall them, here are the steps I took:

  • Search for the plugin in the Extension Manager

  • When the plugin list came up, click on the plugin

  • When t plugin page came up, click on Enable

  • When that finished and the Update page for the plugin loaded, click on Update

Trying to do this via the Manager tab did not work (as was mentioned by others). Hope Trimble will fix this issue.

Found this thread after not being able to update the Trimble Connect extension. This is what worked for me in case it helps anyone else out.

I was getting an “Unable to read extension archive” message for 5 extensions that had updates available.

Four extensions updated successfully through the Extension Manager after logging out and logging back in again.

The Trimble Connect extension would not update in the Extension Manager window after logging out and logging in. The Trimble Connect extension updated successfully from the Extension Warehouse however.

FYI: I had posted that in the 6th post.

1 Like

Cool. So that reinforces the solution for anyone searching for a solution to this issue for the first time.

Be nice if we didn’t have to jump through so many hoops to get an extension that is built in to SketchUp to update properly. Good work Trimble connect!

1 Like

Changing account helps me!

1 Like