SU PRO 2017 White Screen / Blank Screen Activation Issues (Solved)

Client has purchased a stand alone SU 2017 Pro license, software wont allow me to activate it - when attempting to add a license the area to enter the license is blank.

As a test I tried installed SU2019 for testing, it launches but the screen simply remains blank/white.

I’d like to activate the 2017 edition, is there a work around to activate SU using another method?

When did your client purchase a license for SketchUp 2017 Pro and from whom?

License was purchased directly from Trimble/SK site back in Jan. 2017 (based on the time stamp I see they have documented) We ran a repair install SU2017 using an old installer they had tucked on their server. Once it’s launched it remains stuck & does not display the license prompt to re-enter it.

Be sure to have these ports open:
80, 443 and 8080. (5053 and 50530 if networklicense)
Also, sketchup needs access to all *.sketchup.com domains

Confirmed ports are open and access to all *.sketchup.com domains are set. Tested 2016 Make edition as well, it’s loading and does display info correctly. SU 2017 still fails to display anything, 2019 still remains blank/white.

The welcome screen is filled with images from:
C:\Program Files\SketchUp\SketchUp 201X\Resources\en-US\welcomescreen
Is that folder accessible/empty?
Always install being logged in as the normal user and rightclick on the installer file and choose ‘Run as Admin’

Drilled down to that path, looks accessible and did contain some items. Normal user was logged in and run as admin was initiated, I’ll try re-running it again just to confirm.

Did you install SketchUp by right clicking on the downloaded installer and choosing Run as administrator? If not, do so and repair the installation.

Run as administrator used to complete repair installation but problem continued. Tried removing it and reinstalling w/ run as administrator used during reinstall & machine reboots afterwards. 2017 still doesnt load area to input license key, 2016 still working fine.

some more suggestions:
https://help.sketchup.com/en/sketchup/cant-connect-web-tools-3d-warehouse-extension-warehouse-add-location-and-licensing

Still not had any luck, Sketch-up 2017 Make was installed for testing purposes which did load but the sketch-up project area remains blank/white box. If I open up a project and print preview it I see the project is there but it doesn’t display anything on the machine.

To add another wrinkle to things I took the same 2017 installer and transferred it to an older Windows 7 machine - it installed and when launched it displayed the license section without any issues. The current machine suffering the activation issue was previously running windows 7 but was upgraded to 10 earlier this year.

update the video driver first, try disabling “Window > Preferences > OpenGL > Use Fast Feedback” second.

Buy a decent graphics card (Geforce GTX/RTX) third.

1 Like

Thanks, we do have the latest driver package installed.

Video card was also recently upgraded to a GeForce GTX 1650

I am familiar with the fast feedback option but without the ability to input the license for SU 2017 Pro I am unable to launch it and check that option.

Have you considered the possibility of a bad Win 10 install? It does happen.

since SU v2017 for displaying the web-based dialogs the Chromium browser engine is used. Ensure that nothing is blocking anything in the SU program directory as e.g. the concerning “libcef.dll” from running.

And update your profile concerning the used graphics card.

I’ve finally found the solution in case and wanted to post it in case anyone has a similar issue.

Turns out these ‘white overlays’ were visible while using remote tools, in my case I was troubleshooting this machine with Teamviewer and Take Control remote utilities while off-site.

After I connected to the office via VPN and used RDP session to connect to the problematic machine the white ‘overlay’ issues I experienced with the license prompt was not appearing. I was able to successfully activate the software and I have confirmed the project area remained visible once open.

Hope this may help anyone else who may also encounter this problem.

1 Like