SU for iPad crashes when saving

I have removed and re-installed the SU for iPad app with no change with crashing, opened same file in Desktop version of Pro and same file works perfectly. Does anyone have any ideas as what is happening?

How big is the SketchUp model file? What iPad OS version?

iOS 16.2 and model is 1.1mb

If you can upload the model others can open it on their iPads and compare.

1 Like

LL Schematic D Model.skp (1.1 MB)

Does this version of the file show the same behavior?
LL Schematic D Model dr.skp (1.0 MB)

Thank you for looking at the file, unfortunately, the dr file you uploaded still does not save.

Crashes on save on my iPad too. A dialog pops up very briefly about purging, and then poof. I tried manually purging unused, but it still crashes.

The dr version also crashes.

slbaumgartner, thank you for taking a look at the models. I am able to create new files and edit other older files and successfully save with Sketchup for iPad. This issue seems to be isolated with files in which i used Vali’s instant architecture plug-ins(doors and windows). The author of the plug-in has assured me that the plug-in only produces native Sketchup geometry. Vali’s plug-ins are really good so there must be something about the files structure that SU for iPad
doesn’t like. Perhaps the many component groups created by the plug-in is causing a problem?

I noticed odd things like flaps around some of the doorways, but nothing that seemed like it should crash sketchup ipad.

No trouble crashing my iPad as well. I will try to find out what in the file is causing the problem.

@Barry I sent in a crash report.

Thank you Colin

It crashes mine as well. Nothing I deleted allowed me to save so I re-saved it in a new file. Maybe that will help in the meantime?

LL Schematic Re-save.skp (988.0 KB)

Edit:: looks like I lost the ceiling, but that should be easily re-creatable.

I tried saving each tag as its own file, but iPad was ok opening all of those. So then I copied and pasted in place to get them back into one file. It’s missing Interior - Furniture, because that appears to be empty. This new file also opens and saves on iPad ok.

LL New.skp (908.3 KB)

It has a ceiling.

1 Like

Thank you Danimaupin, opens, edits and saves fine. While I tried the save as new file with no change in crashing, it appears to work fine now. Wish I knew what really caused the issue, but thanks again.

1 Like

Thank you Colin, the file indeed works perfectly now. More importantly, both you and Danimaupin revealed that Chuck with Vali Architects was correct that his plug-in should not have caused the issue (Doors and windows are totally intact). Perhaps it was the empty layer.

1 Like

That was a good idea, but the crash happens even with everything on Untagged.

I realized that my version of the file didn’t have your scenes. As another test I deleted the scenes, and the crash still happens.

In the first two scenes, the back edges can’t be turned on.
Did you create the scenes on the desktop?
What style was used?

Yes the scenes were created on the desktop version of SU. There was a scene where a hand drawn line style was used.

Those sketchy edges can be tricky…