SU 22 will not run with Windows 11 & NVIDIA GPU

Sketchup is giving me an error that the graphics card is not supported and the program does not run. I believe that Windows 11 may be part of the problem. Photoshop also gives an error about the OpenGL compatibility, but the program still runs.

The Sketchup Error: “Hardware acceleration is unsupported or has been disabled on your graphics card. Sketchup requires that you use a hardware accelerated graphics card. Unfortunately, these errors will prevent SketchUp from running.”

The windows setting for graphics accelerated GPU scheduling is ON.

The graphics card is the NVIDIA RTX A4500 Laptop GPU. It should have plenty of capability for running any modeling program, in theory.

I’ve tried a handful of different drivers, but none have resolved the issue. The driver I have installed: [517.40-quadro-rtx-desktop-notebook-win10-win11-64bit-international-dch-whql]

Any advice would be welcome!

Are you running a Developer Preview version of Windows 11? There have been several reports about SketchUp not running on one of those.

No, I’m running Windows 11 Education - I work for a University and it’s their computer.

Might be that the Nvidia card is not set up to be displaying SketchUp. Was SketchUp installed on the machine correctly? That requires signing in as your normal user, right clicking on the downloaded installer, and choosing Run as administrator.

If it’s of any use I’m using W11 22H2. SU2022, Enscape etc all working with no problems.
Machine spec: i9-9900k, 64gb ram, 2x M.2 SSD’s, RTX 2070 (8gb)

With luck you’ll find what’s up with your setup.

That’s good to know that it can run in Windows 11. I think my issue is related to the NVIDIA driver not supporting OpenGL (whatever that is).

Here’s a screenshot of my system specs.

I uninstalled SU 22 and then installed SU 21 as administrator to try a different version. I got the same error.

Do you have a monitor plugged in?
If so, unplug it

Right-click on your desktop and select Nvidia Control Panel from the context menu.
Select the “Manage 3D Settings” page. On the right, either in the “Base profile” settings, or “Program settings” for SketchUp, set the “OpenGL rendering GPU” setting to point to your Nvidia card instead of “Auto-select” (Screenshot also from a Dell Precision laptop)

Thanks for all the suggestions. I’ve tried these settings, but nothing has solved the issue unfortunately. I’ve passed off the laptop to our IT department to be reimaged with Windows 10 to see if that solves the compatibility issues with the NVIDIA RTX A4500.

A few days ago I learned about a known issue, where if you have an Intel GPU and an Nvidia GPU, Windows will sometimes claim that your OpenGL version is 1.1. I can make that happen on my work PC. If I am working locally, and I have either the Intel or the Nvidia disabled, but I don’t get the issue. If I have both enabled, and Nvidia set to be used by SketchUp.

What other GPUs do you have, and are they enabled (even if not is use by SketchUp)?

Is it a Dell? I remember cases in the forum where users had to disable their Intel integrated graphics in order for SketchUp to work. They were using Dell laptops. It was some time ago - I wonder if Dell has since issued a firmware update…

In my case if I disable either GPU, then I get the problem. It is a Dell, but desktop, with a GTX GPU.

When trying to figure out why it was telling me Open GL 1.1, I did make sure the drivers were up to date. Still showed 1.1 even though I had Open GL 4.6 installed. The 4.6 showed up ok after I enabled both GPUs.

The University IT department re-imaged my laptop to Windows 10 instead of 11 and all the issues seem to be resolved, no errors with Sketchup or Photoshop. I believe the problem was an incompatibility between Windows 11 and the NVIDIA RTX A4500 GPU.

I had a similar issue way back when updating a Win 7 machine to Win 10, the Nvidia card would just not work with win 10. I reverted to Win 7.
Many months later I tried updating again and by then it worked. Whether it was an update to windows that made it work or an Nvidia driver I’ll never know.

This topic was automatically closed after 186 days. New replies are no longer allowed.