IS there anyway to get SU2016 to run on windows 10?


#1

Just upgraded to windows 10 and sketchup does not seem to be able to handle it at the moment. Overall performance is laggy to the point where things take 3 times as long and then it also crashes every 2-3mins as well… Obviously im doing something wrong or have not done something yet please help… got heaps of work i need to get through!!!

I have tried running through “compatibility” mode and no joy same with running as admin.


#2

It’s running flawlessly for me on Windows 10. Have you tried the latest video card driver?


#3

how do i do that please help


#4

Also running flawlessly for me on Windows 10.

What brand of video card do you have?


#5

Same issue here. Windows 10 works fine for everything except layout in SU 2015 and SU 2016. Crashes, raster images jagged beyond use. Using Nvidia 650 1gb graphics card, which updates it’s own driver. Any suggestions?


#6

Have you tried opening your PC’s Control Panels > Device Manager
and then manually updating the Nvidia GC drivers [right-click context-menu] ?
That will force it to have the latest one…
Also check the Nvidia Control Pane,l to see that the 3d-application is set up to choose its own settings…


#7

Fixed, I think. It appears the antivirus software, for the first time ever, decided to interfere with the program and kept putting it in isolation mode. Turned it off, and now seems to work.