Sketchup not loading anymore after windows 10 update


#1

Recently upgraded to Windows 10 from windows 8 and now get a bugsplat trying to load


#2

Have you tried the compatibility modes? See if that fixes the problem. There were some reports that Windows 10 doesn’t handle SketchUp as well as previous versions.


#3

Yes, I did same result.


#4

And have you tried running the application in Administrator Mode?


#5

No I have not, I can give it a try


#6

It did not work either same thing happened


#7

Hm, that usually solves the problem but your case is probably different. Let’s see what others can say.


#8

Have you updated your Graphics Card’s drivers ?
They need to be Win10 compatible, otherwise it might splat SketchUp [and other Apps using it]…
Have you tried reinstalling SketchUp v2016 as an Admin ?


#9

Pretty sure my graphics card driver was updated after the switch but I will redo and reinstall using admin


#10

Your profile says Intel for graphic card - so no dedicated graphic card, but an integrated graphic chip?

Laptop or desktop?


#11

yeah its integrated…laptop. I can’t seem to find an driver so assuming that is the issue.


#12

Apparently the Intel Graphics Media accelerator is not compatable with Windows 10 but I was able to upgrade which is weird