Can't run SU in Windows 10

Title says it all. The “choose a template” dialog opens fine, then SU starts but rarely gets to drawing the man and the axes before it crashes with an error pop-up from the Nvidia OpenGL driver (Error code 3). I am using the latest Nvidia drivers and have seen this problem with SU 2015, SU 2016 and SU 2016(32 bit), all in admin mode. I have seen comments from other people using multiple non-Nvidia GPUs with similar problems but have found no relief in the suggested solutions. I can’t get SU running long enough to tell it to not use acceleration. Can that be done in the registry? I looked but didn’t see any obvious entry.

I also tried disabling one GPU, leaving only the main GPU (with two displays). SU still crashes…

I have a similar machine at home with a single Nvidia GPU with two displays, Windows 10, and SU Pro 2015 which works just fine.

Here’s the Nvidia info:
NVIDIA System Information report created on: 11/20/2015 15:05:51
System name: ERICMCRAE-PC

[Display]
Operating System: Windows 10 Pro, 64-bit
DirectX version: 11.0
GPU processor: Quadro FX 580
Driver version: 341.35
Direct3D API version: 10
CUDA Cores: 32
Core clock: 450 MHz
Shader clock: 1125 MHz
Memory data rate: 1600 MHz
Memory interface: 128-bit
Total available graphics memory: 4607 MB
Dedicated video memory: 512 MB GDDR3
System video memory: 0 MB
Shared system memory: 4095 MB
Video BIOS version: 62.94.63.00.12
IRQ: Not used
Bus: PCI Express x16 Gen2
Device Id: 10DE 0659 063A10DE
GPU processor: Quadro NVS 295
Driver version: 341.35
Direct3D API version: 10
CUDA Cores: 8
Core clock: 540 MHz
Shader clock: 1300 MHz
Memory data rate: 1404 MHz
Memory interface: 64-bit
Total available graphics memory: 4095 MB
Dedicated video memory: 256 MB GDDR3
System video memory: 0 MB
Shared system memory: 3839 MB
Video BIOS version: 62.98.56.00.11
IRQ: 30
Bus: PCI Express x16 Gen2
Device Id: 10DE 06FD 062E10DE

[Components]

nvui.dll 8.17.13.4135 NVIDIA User Experience Driver Component
nvxdsync.exe 8.17.13.4135 NVIDIA User Experience Driver Component
nvxdplcy.dll 8.17.13.4135 NVIDIA User Experience Driver Component
nvxdbat.dll 8.17.13.4135 NVIDIA User Experience Driver Component
nvxdapix.dll 8.17.13.4135 NVIDIA User Experience Driver Component
NVCPL.DLL 8.17.13.4135 NVIDIA User Experience Driver Component
nvCplUIR.dll 7.8.820.0 NVIDIA Control Panel
nvCplUI.exe 7.8.820.0 NVIDIA Control Panel
nvWSSR.dll 6.14.13.4135 NVIDIA Workstation Server
nvWSS.dll 6.14.13.4135 NVIDIA Workstation Server
nvViTvSR.dll 6.14.13.4135 NVIDIA Video Server
nvViTvS.dll 6.14.13.4135 NVIDIA Video Server
nvDispSR.dll 6.14.13.4135 NVIDIA Display Server
NVMCTRAY.DLL 8.17.13.4135 NVIDIA Media Center Library
nvDispS.dll 6.14.13.4135 NVIDIA Display Server
NVCUDA.DLL 8.17.13.4135 NVIDIA CUDA 6.5.41 driver
nvGameSR.dll 6.14.13.4135 NVIDIA 3D Settings Server
nvGameS.dll 6.14.13.4135 NVIDIA 3D Settings Server

I believe the lastest driver are 341.92. It may help.

Don’t know why that version shows up. I had installed the 341.92 package prior to running my latest attempts. Perhaps Nvidia has a bogus link. Will check that.

OK, re-installed the latest drivers: Problem still exists. SU Make 2016 will not start after selecting template.

Here’s the Nvidia dump:
NVIDIA System Information report created on: 11/23/2015 08:13:29
System name: ERICMCRAE-PC

[Display]
Operating System: Windows 10 Pro, 64-bit
DirectX version: 11.0
GPU processor: Quadro FX 580
Driver version: 341.92
Direct3D API version: 10
CUDA Cores: 32
Core clock: 450 MHz
Shader clock: 1125 MHz
Memory data rate: 1600 MHz
Memory interface: 128-bit
Total available graphics memory: 4607 MB
Dedicated video memory: 512 MB GDDR3
System video memory: 0 MB
Shared system memory: 4095 MB
Video BIOS version: 62.94.63.00.12
IRQ: Not used
Bus: PCI Express x16 Gen2
Device Id: 10DE 0659 063A10DE
GPU processor: Quadro NVS 295
Driver version: 341.92
Direct3D API version: 10
CUDA Cores: 8
Core clock: 540 MHz
Shader clock: 1300 MHz
Memory data rate: 1404 MHz
Memory interface: 64-bit
Total available graphics memory: 4095 MB
Dedicated video memory: 256 MB GDDR3
System video memory: 0 MB
Shared system memory: 3839 MB
Video BIOS version: 62.98.56.00.11
IRQ: 30
Bus: PCI Express x16 Gen2
Device Id: 10DE 06FD 062E10DE

[Components]

nvui.dll 8.17.13.4192 NVIDIA User Experience Driver Component
nvxdsync.exe 8.17.13.4192 NVIDIA User Experience Driver Component
nvxdplcy.dll 8.17.13.4192 NVIDIA User Experience Driver Component
nvxdbat.dll 8.17.13.4192 NVIDIA User Experience Driver Component
nvxdapix.dll 8.17.13.4192 NVIDIA User Experience Driver Component
NVCPL.DLL 8.17.13.4192 NVIDIA User Experience Driver Component
nvCplUIR.dll 7.8.840.0 NVIDIA Control Panel
nvCplUI.exe 7.8.840.0 NVIDIA Control Panel
nvWSSR.dll 6.14.13.4192 NVIDIA Workstation Server
nvWSS.dll 6.14.13.4192 NVIDIA Workstation Server
nvViTvSR.dll 6.14.13.4192 NVIDIA Video Server
nvViTvS.dll 6.14.13.4192 NVIDIA Video Server
nvDispSR.dll 6.14.13.4192 NVIDIA Display Server
NVMCTRAY.DLL 8.17.13.4192 NVIDIA Media Center Library
nvDispS.dll 6.14.13.4192 NVIDIA Display Server
NVCUDA.DLL 8.17.13.4192 NVIDIA CUDA 6.5.51 driver
nvGameSR.dll 6.14.13.4192 NVIDIA 3D Settings Server
nvGameS.dll 6.14.13.4192 NVIDIA 3D Settings Server

Have you run DxDiag?

You could also check and/ or try updating your Intel Graphics Driver, if you have a Intel.

DxDiag shows no problems. Intel, what’s that?

I believe the Intel Graphics is an in-build graphics controller on the Intel CPU chipset. I know of gamers with problem with OpenGL and they fix it by downloading the new drivers from Intel. Check your DxDiag for your version.

Below is an example of my DxDiag, I noted that my driver are out of date for Windows 10.


Name: Intel® HD
Graphics 4600

Device ID:
PCI\VEN_8086&DEV_0412&SUBSYS_D0001458&REV_06\3&11583659&0&10
Driver: C:\WINDOWS\system32\DRIVERS\igdkmd64.sys, 10.18.0015.4256 (English), 7/18/2015 01:36:32, 6389688 bytes
Driver: C:\WINDOWS\system32\igd10iumd64.dll, 10.18.0015.4256 (English), 7/18/2015 01:34:24, 13727296 bytes

Hi, Eric,

I’m sure several other folks will offer their own advice, but here’s mine.

If I remember rightly, the Quadro FX 580 card you’re using is a budget-oriented card that’s several years old now. Yes, that chipset ought to work fine, but clearly, this specific card is misbehaving. I would recommend you purchase a new video card. There are lots of great cards out there for under $100 that should not only allow you to run SketchUp without errors, but also allow you to use full hardware acceleration. Disabling acceleration causes a terrible performance impact. I’m sure once you start regularly using full acceleration, you’ll never want to go back.

Which graphics card to get? Obviously there are lots of potential choices and no one clear answer. For instance though, when I built eight new lab machines in the office earlier this summer, I selected a Gigabyte-branded Nvidia GT 730-based unit with 2GB of memory. At only $80 each, it was a great deal.

There are hundreds of similar cards out there at sub-$100 prices that will work fantastically.

I know replacing hardware probably seems unattractive, but it sounds to me like what you’ve got now is faulty, so when you consider the value of your time, getting a new card may very well be the cheapest solution.

Good luck,

Andrew

1 Like

If I remember right, the Quadro FX 580 is the same generation as my FX 1800 but with somewhat lower specs. Mine still works happily even if it only has 768 MB of memory. I seem to have the latest driver but one.

Are some other versions of Sketchup working? Do you use other 3D software? Are the fans full of dust? Are Antialiasing and Anisotopic filtering set to “Application controlled” in the Nvidia settings?

You mention “Other GPU”. What model and make is that? Did you try physically removing it instead of just disabling?

I think Norbert (@sketch3d_de) has a solution to turning off Hardware acceleration without starting SketchUp.

Anssi

No Intel graphics device shows in DxDiag.txt. I tried Intel’s driver update utility but it found nothing to update on my machine - a 2009 Dell T7500.

In any case, thanks for the tip Anssi. I went to @schech3d_de and found the batch file to update SU preferences directly in the registry. Of course, it’s set up for SU 2015. I manually entered the GfxUseAccelerationOnScreen and GfxUseAccelerationOffScreen (both = DWORD 0) and now I can run SU 2016.

My 2nd GPU is an Nvidia Quadro NVS 295.

Everything worked fine prior to switching from Windows 7 Pro to Windows 10 Pro.

we do not offer batch files, our free support config tools for SU f. Windows (up to version 2016) here.

Windows support for multiple different graphics cards has always been sort of flaky.
The Quadro NVS is a 2D card that doesn’t properly support OpenGL. You should check that SketchUp is using the QuadroFX (is the monitor you use SketchUp on connected to that, and are there switches in the Nvidia 3D application control panel that affect which card SketchUp uses?).

Anssi

You should be able to r-click on the SU icon and have a “Run with graphic processor >” option. You could try that.

@SketchyEric,

You can use the .reg files from the enclosed zip files to disable the hardware acceleration via registry settings. Simply unizp the appropriate file, double-click, and the registry settings should change.

gfx_ha_2015.reg.zip (1.1 KB)gfx_ha_2016.reg.zip (1.1 KB)

Let us know how it goes.

Yogesh

This is something that would benefit from a command-line switch. Not all users have the privileges to change things in the Registry.

Anssi

1 Like

@Anssi, I’ve logged this as a feature request.

Andrew

1 Like

containing the complete Preferences branch including e.g. a configured default template (“Landscape.skp”) with a path probably not working with non-EN-US SketchUp versions etc.

I am having a Similar issue, OpenGL Error the application requested more memory than what is available. Funny… worked fine in Windows 7 only started getting the issue in Windows 10; any suggestions? Is there a patch?
Nvidia Quadro FX 770m 512Mb
(DXDiag Says I got 2Gb going to the Card)
8Gb Ram (6Gb dedicated to System, 2Gb dedicated to GPU, according to DXDiag)
Win 10
Don’t know the Nvidia Driver Number, downloaded it this week so it should be current.
2.9Ghz Core 2 Duo Intel T9600

Installing the latest Nvidia Graphics-Card drivers should ensure Win10 compatibility.
Although the default GC 512Mb rating seems a bit low [but meeting the minimum limit]…

… [v2016 requires]…
3D class Video Card with 512 MB of memory or higher.
Please ensure that the video card driver supports OpenGL version 2.0 or higher [I think yours has v2.1]
and has up to date drivers.

I’d also check the following:

  • Nvidia Control-Panel - is set to allow 3d program to chose its own settings.
  • The SketchUp Preferences > OpenGL setting have various permutations, try different ones. You might need to restart SketchUp after some changes to see the effects…

When used, they shall be antialias jagged in drawing sketchup .I want to modify the original as they must do?