SU 2022 is not loading Extensions

When SU opens, I get the message “Extention Warning, SU crashed the last time it loaded extensions. Continue loading extension” and two options: Skip or load by selecting “load,” SU crashes, bug splat. And nothing. When I select Skip, I don’t have access to my extension but SU works fine. SU has been unstable more often, but when I installed Fredo corner, all extensions failed. I did read something about Enscape being problematic. Any ideas? I reinstalled SU a few times, including deleting the SU 2022 library folder in the application support.
Working on a Macbook Pro from 2019.

thx in advance

When you installed FredoCorner, did you also install the helper extension it requires, LibFredo?

Yes, I did. It actually asked for the Libfredo

Did you also install the required Sketchucation ExtensionStore tool?

I dont think I installed that one. Is that, or could that be the problem? I am looking up the extension store

I don’t know if that’s exactly the problem but it is a required extension to be able to use many of Fredo6’s extensions including FredoCorner.

Right, thanks for the tip. I do think my problem is deeper now than that since my extension manager seems to be inactive, or better, I still get the message of loading with or without an extension. And loaded with “unextepticly quits the program” So now I cannot install any extension, once I try I get “unable to handle rbz files”

Which version of Mac OS are you using?

Monterey version 12.6

It would help if you add that information into your forum profile.

Did you actually go through the proper installation process? Have you done a power off reboot of your computer?

That’s an odd message. I’ve never heard anyone report that before. Maybe @colin has some idea.

1 Like

Install process through the extension Manager, except Enscape, which has its own installer process. Reboot now quite a few times, also reinstalled SU about 2-3 times w/o any progress.

I meant how did you install SketchUp?

As a first step, try renaming the plugins folder so that no extensions can load, and then try launching SketchUp.

If that succeeds without crashing, copy half of your previous extension files back into the plugins folder (SketchUp will have recreated the folder and put some of its own extensions there) Be sure to include both the “registrar” .rb and its associated folder for each. And for extensions that use a support library (e.g. libfredo or ttlib) be sure to restore the library file and folder too. If it again crashes, remove half of what you copied and try again. If it doesn’t crash, restore half of the remaining files. By repeating this half at a time process you will quickly zero in on the offender.

Just by downloading and opening the disk image. Then drag and drop the files in the application folder

Somethings not right with your computer. Others using the same OS version and SketchUp version arene’t having this problem. Check your security settings.

Try deleting the sketchup 2023 entries in the ~/Library/Preferences after exiting SketchUp

Thx, you and dave gave me an idea I had not tried yet. Slightly different from your suggestion. Instead of installing (drag+drop) SU directly in the App folder, I made a subfolder and dropped the applications in there. This seemed to overcome my gridlock problem and for now, it worked, keep my fingers crossed.
Not sure if it all makes sense but thanks for your suggestions.



1 Like

I may be misreading it, but what you wrote leaves me concerned. You should install SketchUp by dragging its icon in the installer dialog onto the Applications icon in that same dialog, as suggested by the big arrow. Do not drag anything into the Applications folder or another folder in Finder, and do not open the dmg and drag anything anywhere from there! Doing otherwise will mess up SketchUp’s expectations about where and how it was installed and can lead to strange errors. If I misunderstood, ignore me.