SU 2020.2 Install Procedure

In reading the release notes, there are notes about fixes to the installer.

What is the recommended procedure for installing 2020.2 update when there is a previous version installed?

Guidance for both Mac and Win would be appreciated.

Thanks …

Addressing only Windows:

Download the Installer file. Then, find it on your local computer RIGHT click it and select “Run as Administrator”.

As this is NOT a major update (as version 19 to 20 was, and version 20 to 21 will be), you are NOT given installation options (unless you have never upgraded from a previous version.)

If you already have a previous version of 20, the installation will NOT clobber any of your user settings, installed extensions, etc.

Note: Selecting “Run as Administrator” is NOT the same as simply running it while logged into an account with Administrator privileges!

I double-clicked and it’s fine. All working and no issues. Guess I’m still just lucky :wink:

I have a question regarding language for the new update 2020.2.
I chose to install the english version but it ends up installed in Swedish vs? Why and how can I change that?

Adding that I am situated in Sweden, but that doesn´t mean I automatically want that vs. Is it an automated thing because of the region even if I choose the english?

I’m dredging this thread up from the bottom to ask for guidance on updating to 2020.2 for Mac.

Checking for updates through the app takes me to the download all page. When I download the 2020.2 installer it wants me to drop the folder into my applications, and returns the standard Mac dialogue " an older SketchUp2020 already exists here, do you want to replace it?" Made me nervous.

This feel more like a fresh version install than an updated within versions. Is this correct for Mac Users, should I be writing over the existing SketchUp 2020 folder? I would appreciate confirmation that this worked out.

I just tried dropping the 2020.2 folder in applications(replacing the old one?), but when I open Sketch up, it still has the old 2020.1 version. Tried restarting my Mac with no luck… any ideas?


@c.hutchins I did a bit of research, took the plunge in overwriting the older version and everything is now working as expected. Previous settings and files were not disturbed when updating, so I can be my own confirmation, everything is fine.

When you open the installer it has a SketchUp icon, when you drop that icon into either the applications folder alias that is right next to it in the installer window or into the proper applications folder you should receive a dialogue window that asks if you want to overwrite the existing file. Did you see that dialogue? You will need to click on “yes” to proceed, did you?

If you did not see that dialogue box then perhaps you put it into the wrong application folder, there is one under the HD for all users and one under your personal user name. Try dropping the sketchup icon from the installer onto the application folder icon next to it in the installer.

Yes I am just sliding the Icon across into applications in the installer.

And clicking “yes” on proceed.

Hopefully that was “Replace” and not “Yes”.

Dragging the folder across onto the Applications alias is the right thing to do. If you’re updating from 2020.1 to 2020.2, it ought to say something about there being an older version there already.

In the disk image window you could go into the SketchUp 2020 folder and confirm that the version shown there is 20.2.

I haven’t looked to see if this would happen, but Finder does have an oddity where when you replace an application and everything path wise is the same, it will report the older version until you log out and in again. So, after moving the folder into Applications, replacing the existing one, open SketchUp and see what the About SketchUp window says.

1 Like

Interesting. I’ve never had that happen, and I don’t log off very often.

You rarely would ever check for the problem.

Actually I usually check after each install to make sure it worked.
Just fussy that way :hugs:

Of course, I currently can’t find anything in the Internet to back up what I claimed. I’ll work on that. In about two months it will be the 33rd anniversary of when I started using Mac full time, and I’m not sure how far back you would need to go to see reports of the Get Info issue.

In case you think I’m that new to Apple gear, don’t worry, I was using Apple II from October 1980.

Speaking of anniversaries, I just noticed a cake icon next to my entries. Apparently I’ve been using this forum since today some previous year. 2015 I think.


Yes “replace” have tried downloading 20.2 again with no luck, still shows 20.1.228

I don’t know why you get that results, but I will private message you link that ought to work.

OK Colin… that seems to have done the trick… not sure why the installer wouldn’t over-write the older version

thanks for your help!