SU 2019 in RDS

Hi Guy,

Is it possible to works with SU 2019 in RDS ( RDP , Remote desktop Service ) on Win 2016 Server installed on physical server.

Hardware acceleration is not supported or disabled on your graphics card. SketchUp needs you to use an accelerated graphics card.

In Console working normaly.

Graphics card : Nvidia Gefoce GTX 1080 Ti

Thanks for your reply

This thread and comments might be worth reading:

Yes, i understand you, but it’s not a virtual environnement, the RDS service is directly on physical server.

The key part is that Remote Desktop is not supported at this time.

Thanks for your reactivity, i will forward this information to my customer


Ok, so why aren’t remote desktops supported in this day and age? Really this is only going to become more and more common, can we please get this support? If you had such support, I know our company would be buying more licenses.

I’m not the one who makes up the rules and it’s not me who has anything to say about it. I don’t work for Trimble.

Be that as it may, they have people who do work for them visiting these boards, this is something that needs to be done.

I’m hazarding a guess here.

It likely has to do with SketchUp’s requirement for a minimum level of Open GL graphics processor capability. Remote desktop’s generate the screen image on the host computer and send the screen to the remote computer or thin client.

It could also be that SketchUp would need a new “under the hood” licensing model to allow non-network licenses to work in a server environment, while guarding against more than 1 user simultaneously using SketchUp.

Or both.

And I do mean 1 user. Although SketchUp Pro allows installation on up to two computers, it does NOT allow simultaneous use of the 2 installations.

1 Like

I was on a screen share with someone the other day, the IT support person, who I found out after a while was remoted into the Windows 10 machine I was looking at. Even with both of us effectively doing a remote desktop session to the machine, SketchUp work fine. Well, not at first, because it was crashing, but once I figured out why that was, SketchUp was fine.

So, controlling a PC remotely can be done. It may be RDP in particular that fails, and in that case if you can open SketchUp before you connect, it will probably work.

I would be perfectly ok with requiring a network license (as long as they dropped the minimum number of users to get one down to two or so).

Remote desktops are also perfectly capable of having Open GL graphics capability, but it still won’t work on systems that have it unless you go to an older version of SketchUp and considering how many businesses are moving to a model of using cloud based computing these days (including ones that use Revit and AutoCAD), this is something that is absolutely necessary.

It would be impossible to start SketchUp before connecting, as our systems are all remotely run on AWS servers, which are perfectly capable of running AutoCAD and Revit, even rendering works well.

So you are running virtual machines instead of simply RDP:ing. I have tried successfully (v.2018 was the latest version I tried) to run SketchUp on a virtual machine running on a Citrix platform that had a Nvidia graphics system (forgot the details). It worked perfectly, even when connecting through a 3G mobile phone.

Lucky you, we just get an error that it isn’t supported.

It is probably about OpenGL. AutoCad and Revit don’t use OpenGL but DirectX. As in the system I tested, OpenGL probably needs special hardware at the server end to work.