SketchUp can not run through window RDP?

Sketch up can running normally in PC.

If using window remote desktop to the PC and running the Sketch UP, It will pop error message like below. Also running a display card check have the error.

Please advice how can we fix this issue. Many thanks.
Our display card is NVIDIA GT730 2GB DP DVI PCIe x8 GFX

Checked that running in local PC without RDP is normal.

:eyeglasses:

SketchUp Hardware and Software Requirements …

Virtualized Environments
At this time, SketchUp doesn’t support operation in a virtualized environments such as VMWare or Citrix.
Per the SketchUp Pro License in section 1.1: You may not use or host the Software in a virtual server environment.

Boot Camp/Parallels/VMWare
Neither Boot Camp, VMWare nor Parallels are supported environments.

Remote Desktop Connections
Due to hardware restrictions in shared environments we can’t reliably predict how SketchUp will perform. At this time SketchUp is not supported via a Remote Desktop Connection (RDC) on any platform.

The main problem is that a virtual desktop uses a virtual machine with a software simulated graphics card that cannot support hardware acceleration (because it is not real hardware.)

2 Likes

Pretty sure that it’s listed in the SketchUp requirements that remote desktops are not supported. But, some people have still used it by making sure SketchUp is open before connecting via RDP.

1 Like

btw, for a screenshot of the active window do a “Alt+Print” which copies the screenshot to the Windows clipboard and allows you to insert in your posting here or an image processor for e.g. trimming purposes by pasting via “Ctrl-V”.

1 Like

NVidia only allows remote accelerated 3d graphics on high end (Quadro and above) graphics cards.

ATI and Intel allow any at all time.

You can circumvent this on an NVidia card by starting SU at the computer, let it get running with a drawing context, and then remotely log in.

There are two ways to accomplish this. There’s an easy way and a little bit harder way. The easy way is just to use TeamViewer instead of RDP. If you’re using it for commercial purposes, you’ll need to pay for it. If it’s just personal, it’s free. I was using RDP prior to TeamViewer. To get RDP to work, you can just create a simple batch file to disconnect your RDP session and start sketchup. Then just wait however long it takes for sketchup to start and then connect back in.

or AnyDesk …but be aware, that the companies behind them could see what is transferred, therefore maybe not the best choice if something really confidential needs to be done.

If that’s a concern, Teamviewer has the option to connect over the LAN instead of route through their servers. I’ve never used anydesk, so can’t speak to that. In my case, I have a high end desktop in my basement that I remote into from my laptop when I’m home. That way I can still spend time with the wife and kids and not be relegated to the basement office by myself. I just use the local address instead of routing through Teamviewer’s servers. If I’m not home, I connect in through my VPN and then use the local address.

If you don’t want to go the Teamviewer or AnyDesk route you just need two lines in the .bat file. Here’s mine.

for /F “tokens=1,2,3,4,5” %%A in (’“query session | find “Active””’) DO ( tscon %%C /dest:console)
start “” “C:\Users\Public\Desktop\Sketchup 2019”

In my case, this starts Sketchup using the shortcut on my desktop. Depending on your specific configuration, you might need to modify the path.

1 Like