SU 2018 - Undocked toolbars upon load - window focus bug

userinterface
bug

#1

I’ve been unable to place my toolbar extensions/plugins without them reverting to their undocked behavior the next time I start Sketchup.

I originally installed v2018 as my username - same as for 2017 version back in March and had no similar trouble then.

  1. Initially I tried reinstalling su2018 with “Install as Admin”. - didn’t work

  2. Next I tried running Sketchup itself as admin ‘every time’, but still didn’t work, so I’ve put it back to running as my username

  3. Checked permissions of the C:\Users\myUsername\AppData\Roaming\SketchUp\SketchUp 2018\SketchUp\SharedPreferences.json file - my username has full read and write permissions. So does the login_session.dat file.

  4. Checked the Su2017 Templates folder and found my saved template. No files in the 2018 Templates folder, so I created a new template of Architectural Style there, hoping this would ‘kick things in’.

When su2018 starts up this time, there is room and spacing on the toolbar to place the plugins, as I had just laid them out but they don’t load into the toolbar. (See attached image)

Additional info: Just noticed that whenever sketchup 2018 starts, the screen will show sketchup until it’s about to load the toolbar, then whatever Windows screen I have in the background will move to the front, then the plugins will load, undocked. It appears to be a window-focus bug.

Cheers,
Brett.


#2

I have the same problem.
My computer is in a Domain and the user’s profiles are stored in the server, but in Sketchup 2017 every thing works ok


#3

Actually I’m having the same problem too on my PC


#4

This kind of weird and unpredictable issue can often result from an incorrect installation.
Toolbar states and locations/docking etc should be remembered across sessions.

You should be able to install and use SketchUp as an ‘ordinary’ user - irrespective of your ‘admin’ powers.
It is not advisable to login and run apps, as the dedicated administrator.
It is also not advisable to set SketchUp to ‘always run as administrator’ - this elevates SketchUp’s process above that of Windows Explorer and breaks certain functions like ‘drag-and-drop’…

For the avoidance of doubt…
Here is the correct [and only proper] procedure…
As an ordinary user [doesn’t actually matter if you also have admin powers].
If it’s open, then close SketchUp’s windows.
Find the SketchUp Installer exe file - usually in your Downloads folder.
Select its icon, right-click > context-menu >
"Run as administrator"
When prompted choose "Repair"
When it’s done double-check that the SketchUp exe file is not set to ‘always run as administrator’.
Now restart SketchUp and adjust some toolbars.
Close it and reopen it.
Have the Toolbar changes been remembered ?

If it’s still flaky try repeating the process - but when prompted choose “Uninstall”…
Now immediately reinstall it using the same steps…
Let it install in its preferred default locations.

Not sure how your user-profiles are on a server ?
Aren’t they in the AppData tree ?

The user’s Templates, custom Plugins etc should survive the process…

Toolbar settings should have nothing to do with a Template’s set up, they are remembered with SketchUp on a per-user basis - assuming that SketchUp is properly installed…


#5

Well, I went back to the download page and looked more closely: Here are the instructions for rights when installing. You must be logged in as a user with admin rights in order to install. My account does have admin rights insofar as I’m able to install software without issue… and yet.

Here’s the whole blurb:

A Note about permissions

PC - In order to successfully install and authorize SketchUp Pro, you must first log in to Windows as a user who has either Administrator or Power User rights.

Once successfully installed and authorized, SketchUp Pro requires a Windows profile with at least Power User permissions. You may need to contact your Help Desk or IT department to assist you with these changes.

Tip: Installing SketchUp 2018 does not install over older major versions of SketchUp. Multiple versions of SketchUp can be installed on the same computer. But if you don’t need the older versions, uninstalling those versions makes a tidier computer.
Windows After downloading the file, follow these steps to install SketchUp:

Log in to the computer with a user account that has administrator rights.
Double-click the EXE install file. You can also context-click and select Run As an Administrator.
Click Next in the Welcome dialog box.
Click on the I accept the terms of this license agreement button in the End User License Agreement if you agree to the terms.
Click the Next button to install SketchUp in the default location.
Click the Install button if you’re satisfied with the settings.
Click the Finish button when prompted.
Windows 7/Windows 8: Be sure to close SketchUp Pro after installing prior to authorizing.
Launch SketchUp once before logging out of the administrative user account. If you have a SketchUp Pro license, please be aware that you must authorize while logged in to an administrative account. See the links below for help authorizing.


#6

Forget all of that.
Use the context-menu to "Run as administrator"
This will do everything that is needed.
The guidance you quote is confusing, if not ‘pants’.
It should have been corrected long ago. :thinking:
Too many at Trimble/SketchUp are blinkered MAC users, and thereby they fail to understand the [simple] basis of PC installations, and regurgitate this out of date advice…

Do NOT double-click the installer file - use right-click and “Run as administrator”…
It is NOT the same as double-clicking when you have admin powers.
It is NOT the same as you being the administrator and double-clicking.
It is not just applicable to SketchUp - it applies to any complex app you might install on your PC !

If you don’t believe me try these other sages etc…



There are dozens of similar posts if you do a search…


#7

Tig,

I can’t disagree with much of what you say, but if you read my entire post, I’ve already performed these steps and more.
This is why I posted it as a bug, not an annoyance.

The sketchup docs say I need certain permissions. I have them.
I tried as my regular username, and with Run As Admin - which works out to the same thing really, since I have Admin rights as a user. I tried repairing, and uninstalling with a reboot inbetween, ‘just to be sure’. No dice.

I’m still calling it a bug for now.


#8

No, it doesn’t. Run as Administrator conveys elevated privileges not normally active even when you log on as an Administrator.


#9

To be honest, I have never seen any difference. I wonder if it might be an issue with some third party antivirus/firewall application? The computers where I have successfully installed many kinds of software by logging in with an administrator account use Symantec, F-Secure or McAfee.


#10

it strikes me that it’s the ‘Installer’ that needs these elevated privileges, rather than SU which it is installing…

I can’t see why the ‘Installer’ can’t generate a message if it has the wrong permissions…

but, I’m on a mac and it’s really hard to install thing wrong… [but it is doable]

john


#11

Seems more likely it has to do with the specific configuration of the user’s PC, for example whether other needed libraries are already in place and what permissions were set when such precursors were installed, or maybe something to do with registry permissions.

Indeed, some people install with a simple double-click and get no problems. But there are also a lot of cases being reported where SketchUp goes whacko until/unless installed with the right-click Run As Administrator. So this is the only way to be completely sure it will be ok (assuming there aren’t other problems such as inadequate graphics drivers).


#12

How to fixed.

  1. Close SketchUp Application.
  2. Press Win+R to open run dialog.
  3. Type “%localappdata%\SketchUp\SketchUp 2018\SketchUp” and press enter.
  4. Open file “PrivatePreferences.json” with notepad or text editor applications.
  5. Scorll down to find like this below.

Example:
“RubyWorkspace\ToolbarsUser-Bar0”: {
“BarID”: 59648
"BarName": “Artisan”
},

  1. Remember number of “BarID” and Scorll up to find like this below.

Example from Step 4
"RubyWorkspace\RubyToolbar-59648" {
“Columns”: 0, <== Number of columns (0 = Default, 1 = Fix to 1 Columns, 2 = Fix to 2 Columns, etc.)
“DockBarId”: 0, <== Change Number 0 to 59419
"Visible": 0 <== Change Number 0 to 1 (0 = false, 1 = true)
},

  1. Save
  2. Open SketchUp
  3. Move Toolbar to Docking any Position

PS: Sorry for my english language

Note: Tonight I will uploade video how to fixed it on my youtube channel (TONYWINStheCHANNEL) with thai language.


#13

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.