All tool plugins have undocked

So working away happily last night, sketchup crashes, reopen and all my plugins have undocked themselves from the toolbar. I can put them all back, but out of interest is there a quick way to do this, or is this a known thing that can happen from time to time? Have tried opening new file, and some older ones and the tools are like the screenshot attached.

I’ve seen that recently during a training session, every restart the interface would reset like that.

first, check if bringing back the side tray and moving a few toolbars, then restarting sketchup works. if so, you just have to reset your interface once.

if every time you restart it resets, then…

I solved it by repairing the install :

download the installer, right-click on it / run as administrator,
if prompted, choose repair. if it doesn’t offer you to repair, reinstall (on top of the existing installation)

Yer for me it’s happening on every restart which is rather annoying. I did as you said, and saved the file, but even reopening that it’s still undocking them.

I will download and run as admin, hopefully sorts it, why do these things happen when you are super busy!

Will report back if fixed!

I’ve found that SU saves interface positions when you save a file, ie, if you move a toolbar and then close/reopen SU the toolbar will be back at its original location BUT …
If you move it, save the current file; even just an empty one (I usually save it to xx.skp on my desktop) and then close/reopen SU it will/should have stuck to the new position.

Yer that’s what I have done in the past and it would usually work, this was an odd one. However running as Admin on instal and it’s fixed things, probably a good excuse to spring clean the plugins and simplify the toolbars a bit! Thanks for the help team

Have a look at the Lord Of Toolbars plugin on Sketchucation, you can build your own toolbar(s) so for example, if there is one button you use regularly but to use it you have to have a toolbar of 20 buttons open to see it, you can have just that one button on your own toolbar without the other 19.

This is my set, the last 4 are menu items that don’t normally have buttons.

Yer I have been meaning to set that up, maybe this is the kick I needed!

Before you do, read the last pages in the LOTT thread on Sketchucation so you are aware of the limitations with it in SU2023.

Much appreciated for the heads up DaveR

1 Like

Ahh, bugger!
I’m still on 22 (tried 23 for 10mins and noped out) so everything is working for me.

FWIW, the thing with the toolbars becoming undocked like you showed would happen if something occurred to delete or corrupt a file called PrivatePreferences.json. On Windows this is in a normally hidden folder under User/AppData. If you had originally not installed SketchUp using the right click, run as administrator process it’s possible that Windows didn’t grant SketchUp the correct permissions to write to that file correctly. The crash probably exacerbated the issue. At least you appear to have it sorted out now.