SU 2018 no internet connection error

Thank you this worked for me.

None of the above options worked for me. Was accessing the 3D warehouse fine until a couple of days ago. Internet is working fine. Any other solutions?

Got it working after I cut the file from the folder it was in, placed it on the desktop, modified and saved it, and pasted it back in the folder.

Won’t allow me to modify it in the folder it is in, and won’t work with a copy of the file, you need to cut and paste the original file to the desktop, modify it and put it back.

Working with ONLINE_TEST_URL=http://www.bing.com

If you’re using SketchUp 2018 as your profile says, you’ll no longer be able to access 3dWH from within SketchUp.

That URL should include https, not http.

1 Like

Oh ho ho! That’s news I’ve not heard :wink:

This worked for me, thankfully, using https://www.bing.com and editing the dat file on desktop just as described above. Being able to Geolocate a model is mission critical for business…Thank you!

For your interest, I did go on to post this Known Issue, in the hope people will find the solution quicker:

https://forums.sketchup.com/t/sketchup-thinks-you-dont-have-an-internet-connection/170862/4

1 Like

Google didn’t work, but bing did!

Many thanks.

That fix worked for me - thanks!!!
Closed Sketchup 2018 - in C:\Program Files\SketchUp\SketchUp 2018\Resources\en-US located file i18n.dat - opened with Notepad++ - replaced “Google” by “http://www.bing.com” - restarted SU2018 = it worked - Thanks again!!!

Got the same problem. Still fighting. There still is message “3D warehouse requires internet connection” when i click on 3d warehouse icon.
BUT! When I go for File>3d Warehouse>share model i can access 3D warehouse and download models!!
This is weird AF. Can some one help me.
Changed to https://www.bing.com

The way in which the different features check for an Internet connection seems to vary. If you have modified the right i18n.dat file it should fix each case.

It would be deleting the webcahce folder, that is in here:

%AppData%\SketchUp\SketchUp 2018\

in case something is cached and making it fail.

Also, reopen C:\Program Files\SketchUp\SketchUp 2018\Resources\en-US\i18n.dat to be sure that your edits have been saved ok.

Thank You Colin for reply. I will check that tomorrow but I did everything exactly like other members above. Same bing link with “S” in https. For now It doesn’t work. Also same “info about no connection” when I go to plugin manager. Crazy stuff that worked fine about month ago…

Early on I had quoted from an older post, and that post had an error in it. The whole line should read like this:

"OnlineTestURL": "https://www.bing.com",

I realized later that is the change for 2019 and later. For 2018 it is this:

ONLINE_TEST_URL=https://www.bing.com

Colin-

I’ve been trying without successd to make it work with that line, with both google.com and bing.com, and could not make it work. However, an earlier post by you said to enter it with the forward slash at the end- and that worked instantly. I don’t know enough to know why that made a difference, but it sure did. Thanks a MILLION for figuring all this out, its really appreciated!

ONLINE_TEST_URL=https://www.bing.com/

1 Like

That is curious, I hadn’t yet seen a case where the / was needed. I do often add myself. I will add a note to my article about this, in case that is the solution needed for other people.

Hello, for me the “/” was also needed. Maybe because I’m on Windows 7 Pro 64 bit on my main workstation. On Windows 10 the “/” wasn’t needed (my laptop). On both computers I am using SketchUp2018 Pro.

Thanks for the report. It could well be needed for Windows 7, given that mattwaddington1 is also on Windows 7.


I also have a problem with the Generate report. I have sketchup Pro 2016 and windows 10. I solved the problem with a right click on the stuck reports window. A menu appears on the jammed report window. I selected “Update”(lithuania language “Naujinti”) from the menu. I tried everything with i18n.dat but no one helped.

What a relief!
Was desperate to find a solution for this strange problem, so happy to read your post. It totally worked. Thank you!

OSX Big Sur (11.6)
SU2018
Podium 2.5