SketchUp does not see internet connection even though IE is up-to-date and using Windows 10


#1

The opening sentence says it all. I’m using SketchUp 2016 with the latest IE and Windows 10, but yet, SketchUp does not see my internet connection. So, I cannot access 3D Warehouse, or use Geolocation to bring in Google Earth terrain. I’ve tried pretty much every option I could find through Google searches.


#2

Do any of the SketchUp experts on here have a solution for my problem?

Thanks!


#3

does it have worked already?
behind a company proxy?
(new) security suite w/ firewall installed?

do the common:
• update operating system and the browser of the operating system (Win = MS IE; not Mozilla, Chrome, Opera etc.)
• empty the cache of browser
• delete cookies of domain *.sketchup.com in browser
• MS IE: set the internet security zone not higher than the default “medium high”

hth


#4

I’ve done all that without any success. My next step is to change the line,
ONLINE_TEST_URL=http://www.google.com/ncr, in the i18n.dat file to something more recognizable, but I’m getting an Access Denied prompt when I try to save it. When I put the URL, http://www.google.com/ncr, into the address window, it’s like it doesn’t even exist.


#5

does it have worked already?
behind a company proxy?
(new) security suite w/ firewall installed?

save the changed file “i18n.dat” to the Windows desktop and move than to the appropriate destination directory, admin. rights are required for doing the latter.

if accessing the URL “http://www.google.com/ncr” via the MS Internext Explorer (not Firefox, not Chrome, not Opera etc.) is not possible, there is obviously something wrong with your system and in cosnequence SU not able to check for an internet access.


#6

Can someone, please, tell me why this site: http://www.google.com/ncr, does not exist?


#7

this URL does work of course, if not your system is causing the problem.


#8

The location is within the %ProgramFiles% folder hierarchy.
Access requires administrative privileges.

(1) Did you install SketchUp by right-clicking the installer exe, and choosing “Run as administrator” ? (If not re-run the installer like this, and choose “Repair”.)

(2) Is the SketchUp icon (shortcut) set to “Run as administrator” ? (If not, right-click the icon, and choose “Properties”. Switch to the “Compatibility” tab of the dialog. At the bottom, check the box, to “Run as administrator”.


#9

Dan, Run as administrator did the trick.

Thanks!

P.S. Now, all I need to figure out is hoe to add more imagery. i get it to come up, but it isn’t giving me the option to add it to imagery I just brought in.


#10

Excellent. Has this solved your Web dialog issues as well ?


#11

This is strange. I tried to add more imagery, which did not work. I’ve even tried starting with a whole new project. I can get the Geo-Location to come up, but, now, it will not let me add any imagery to a project.


#12

How is it not letting you add imagery?


#13

Could it be that the Dialog needs to be resized a bit so you can see the grab button?


#14

I’m beginning to believe I’m having internet issues. I think it may either be my provider, TWC, and/or I may need a new beefier wifi router. I did get it to add Geo-Location imagery, once. Now, it is back to saying it appears my computer is offline. I just cannot figure out why I can access the internet with the very same computer that SkethUp is running on and telling me Imy computer appears to be offline. o.O


#15

This usually indicates a timeout setting that is too short in duration.


#16

Is that a timeout on the internet, or SketchUp and how do I fix it?


#17

I’ve tried all kinds og things to fix the timeout issue, even going into regedit and add a KeepAliveTimeout, but still no success.


#18

Are you using secure DNS servers by chance ? They could be blocking *.sketchup.com and *.trimble.com websites.

And you have made sure to add these two servers above to your trusted sites list ?
Control Panel > Internet Options > Security > Trusted Sites

If not, add them and try again.

SketchUp uses Internet Explorer for webdialogs. So I would suspect the setting may be related to MSIE. EDIT: The default timeout for the handshake is 15 seconds.
https://msdn.microsoft.com/en-us/library/ee330736(v=vs.85).aspx#websocket_closetimeout

You could test opening another webpage from inside a SketchUp WebDialog frame.

This little script opens the online HTML5 game Bejeweled by PopCap, inside a SketchUp WebDialog frame.
Bejeweled.rb (1.1 KB)


#19

I added *.sketchup.com and *.trimble.com to Trusted Sites. That did not help. I was able to run the Bejeweled script just fine. Do you have the exact script and location I should put it in when I use regedit to add this? Also, Am I shooting for the 15 seconds, or do I want to suppress the time, completely? Also, I will tell you that IE 11 does not load very quickly on my computer. I was wondering if that could be a factor.


#20

I just saw that this Folder is missing: FEATURE_WEBSOCKET_CLOSETIMEOUT Should I add it and a value in it?