SketchUp 2014 adding geo locations no internet connections


#1

hello fellows, I know this is an issue that seems to have troubled many, I have searched a bit on google and on these forums briefly, but can not find any good advice.
Note…Please do not advice me to upgrade to 2017, I have tried those versions but those won´t even let me install properly, first I had issues with microsoft frameworkd, finally I got the offline framework and that worked…almost, then I got missing dlls, so I gave up on 2016.

I have downloaded 2014 which installed nicely without those issues, but now I am encountering this issue with no internet connection.
I do not use internet explorer…last time used was version 8, not gonna use any other iexplorer… my default browser is firefox though, and that is what I use and want to use, I have cleared internet cache in both firefox, chrome and internet explorer, I have added sketchup 2014.exe as a program to be allowed through windows 7 firewall, I have exluded it in avast, I have restarted the computer, running it in both administration mode and not…but nothing helps here, I still get no internet connection when trying in sketchup 2014 make.

windows 7 and firefox 6.2.0 is my default system and avast as antivirus, but the firewall is windows 7.


#2

It doesn’t matter what Internet browser you want to use, SketchUp 2014 and every other version up through SU2016 uses Internet Explorer and it needs to be up to date.


#3

Thanks for a very fast reply, However, that wasn´t the issue here, I just solved it.
Granted…it uses internet explorer for the maps, I would however suggest you guys seriously consider other browsers as well.

what I did…using not the latest IE explorer, but using IE explorer 8, that was to change the advanced options, and checked the Tlss protocols that was unchecked, once I did that …then I suddently could use the geolocations and succesfully extract a map from google, although with a warning that I use an older version that isn´t supported, but it worked anyway.

I am not fond of using IE explorer though, and reluctantly will install it only if Absolutly needed.

while I am at it, why did you guys remove options to download models from version 8? dissapointed about that…but there you go.

the warehouse download also works now.

Thanks for your quick reply


#4

You’ve already rejected SketchUp 2017 so this is moot. As I said before, older versions of SketchUp on Windows use IE and that’s all there is to it.

SketchUp 8 is ancient and hasn’t been supported for years. At some point there comes a time when services like creating SketchUp 8 files for the warehouse is not a good investment of resources.

By the way, you write as if you think I work for Trimble. I don’t.


#5

Sorry …my mistake, must have read your profile wrong, so that is clear.

and I really could be well off with just sketchup 8 …if it weren´t for the fact that you no longer can download geolocations with that, nor download models directly to sketchup, and no more version 8 models from now on.

So why would I use sketchup 8, well…there was a guy who wrote a good plugin for exporting to lighwave, and I think that plugin only worked wth version 8 and not later version…unfortunatly this guy hasn´t updated that nor can be seen around it seems.

As far as no good investment by creating version 8 models, that I could maybe agree on, though if the sketchup versions of late would be easier to install as the old ones were, I wouldn´t have that much problem with it, but as it is now…I still have to track down installation files here and there to get it to work with latest versions, 2014…now works, but I will go with that for a while.

and why not later sketchup versions, well…I can´t even get them installed cause they require some missing dlls, and there was so much hassle with it as well with microsoft framework not installing properly, even though I got that to install after using the offline installer, I still got issues with api runtime dlls after that, so I just go fed up with the whole installation and gave up, a fellow lightwave suggested that I would skip sketchup 2017…and also because they even have limited export and removed collada, so that is what I did.

Anyway…it is all working now, with sketchup 2014 and both geolocations and warehouse imports without me using any update of internet explorer, it still goes with internet explorer 8, though the browser google map api isn´t supporting fully, so there may be errors ahead sometimes.


#6

Well, I guess since you’re using it for hobby stuff and you are getting it for free…

If there are missing dlls on your computer could be replaced. The fact they are missing from your computer is not the fault of SketchUp or Trimble. I’ve installed every version of SketchUp since V3 on multiple computers and I’ve not had any problems. I’ve got SketchUp 2017 installed on four different computers and they all installed without a hitch. It isn’t difficult to install if the system requirements are met and it is installed correctly.


#7

This is because Google no longer supports MSIE below v10. So if you have MSIE v10 or v11 installed, you can change the BROWSER_EMULATION registry key for "sketchup.exe" to 10 or 11, and the Google Maps warning will go away.

SketchUp installers for 2014 and below set emulation to MSIE 8.

SketchUp installers for 2015 and 2016 set emulation to MSIE 9.

The SketchUp 2017 installers sets MSIE emulation to 11.

See this post for some reg files that you can use to change the emulation setting.
Geo Location and terrain import error

If you’re running Win7, I’d recommend updating MSIE to 11 with all the latest updates, and running sketchup.exe’s browser_emulation at 11. (Going forward, this will be best compatible with SketchUp’s web features like 3D Warehouse and Extension Warehouse.)