Adding location error message

addlocation

#1

When I click to add a location I get an error message: You are using a browser that is not supported by the Google Maps JavaScript API. Consider changing your browser." My default browser is Google Chrome and I have disabled IE. Can anyone provide suggestions.


#2

While you might use Chrome as your default browser, SketchUp uses IE. You need to keep IE active and up to date.


#3

I reactivate it and update it, thanks


#4

Google has been tinkering with the “Google Maps JavaScript API” used by external apps such as SketchUp. The tinkering has narrowed the suite of browser versions that will work. In particular, older versions of IE are no longer supported.

As Dave has correctly pointed out, SketchUp uses the system browser library that Windows installs behind IE (on Mac it uses the WebKit library that underlies Safari). It does not matter what other browsers you have installed or what is your default. If IE is out of date, the Maps API will tell you your browser is not supported.


#5

The message is a warning. It says “Consider changing your browser.”

Try using the dismiss choice, and use as you normally world if you cannot update MSIE to version 10 or later. (If you can update to version 11 that will be even better.)


#6

I had turned off IE because I don’t use it. But now that I have turned it back on and updated it the message has disappeared.

thanks


#7

It does not matter what YOU use externally as your preferred web browser,… (I myself use Comodo Dragon,) … SketchUp uses a Microsoft library DLL file from IE, for it’s internal browser windows on MS Windows, and the WebKit library from Safari on the Mac editions.


#8

go figure, a Google product not using Google Chrome as it’s browser


#9

What Google product are you referring to?

SketchUp uses the native OS-supplied browser because that’s the only one they can be sure will be installed on the computer.

SketchUp isn’t a Google product.


#10

Isn’t sketchup a google product?


#11

Sketchup was originally an independent program, it was bought by Google who developed it for a few years before selling it on to Trimble.
It’s at least four years since Google was involved.


#12

Google did buy SketchUp from its originators @Last [1999-2006].
It was then sold on to Trimble [Navigation] in 2012.

It is still based in Boulder CO.


#13

What Box and TIG wrote.


#14

Hello all, new here and learning to use SketchUp Make.
I too am getting the “You are using a browser that is not supported by the Google Maps JavaScript API. Consider changing your browser.” error message when I try to add a location.

I’m running SketchUp 2016 on an HP G72 laptop under Windows 7 Home Premium. Windows Update says that there no updates available for my computer.

My IE version is Version: 11.0.9600.18524 Update Versions: 11.0.37 (KB3197655)

It doesn’t matter what browser is set as the default, IE, Firefox or Chrome, I get the error message.

I am able to import images from Google Earth. Although the images leave a lot to be desired, especially when zoomed in, that is likely due to the data itself.

So, why is SketchUp giving me this error message when I have most recent versions of these browsers installed?


#15

Oh yes, I was forgetting. Windows is 64-bit.


#16

It is NOT SketchUp giving the error message.

It is the Google Maps API. The message itself says so.

Because internally, SketchUp is using a MSIE frame for it’s Add Location WebDialog.
The SketchUp installer (since v2014) sets a systemwide IE version emulation registry attribute to IE9.

You have a choice. You can manually set it to 10 or 11, if you know how, and dare.
(I’ve covered how to in several other topic threads, search on “browser emulation”.)

Or, you can just install SketchUp 2017 (even if you do not intend to use it.)
It’s installer will set this browser emulation attribute to MSIE v 11.


#17

Thanks @DanRathbun,

I applied your registry change for the browser emulation. No error message now, adding a new location worked fine. There is even terrain info that wasn’t there before.
As to your suggestion about installing 2017, see the info at the bottom of this post.

Computer info:
HP G72 Notebook PC
Processor: Pentium® Dual-Core CPU T4500 @ 2.30GHz
RAM: 3.00GB

Graphics Monitors:
Generic PnP Monitor (1600x900@60Hz) (built-in screen)
VW26L HDTV10F F (1600x900@30Hz) (sometimes, on HDMI port)
Graphics Hardware:
Intel Mobile Intel 4 Series Express Chipset Family (HP)
Driver Provider: Intel Corp
Driver Version: 8.15.10.2302
Intel Mobile Intel 4 Series Express Chipset Family (HP)

Windows 7 Home Premium 64-bit Version 6.1.7601 Service Pack 1 Build 7601 (all updates installed)
IE version: Version 11.0.9600.18524 - Update Versions: 11.0.37 (KB3197655)

SketchUp Make 2016 Version 16.1.1449 64-bit

The above Intel chipset does not support OpenGL 3.0

SketchUp CheckUp 2017 reports that the OpenGL version is 2.1. There are no updated graphics drivers available from HP or Intel.
Also, SketchUp wants at least 4GB of RAM, it will run on 3 but it wants more.

All other requirements for 2017 were met.

All things considered, installing 2017 on this notebook would be a waste of disc space.


#18

I agree. I have the same chipset in my ol’ day to day Dell Inspiron N5030 notebook. (I just didn’t know how comfy you were with making registry changes.)


#19

Fairly comfortable. I’ve been making the occasional change to the Windows registry since I started using Win98. And making changes to the system environment in MS-DOS before that, (I started out using MS-DOS 3.1.) Besides installing and using various flavors of Linux on different computers.

Thanks again.