Geo Location and terrain import error

So… I’m getting a lot of interesting errors when trying to geo locate in sketchup.

“You are using a browser that is not supported by the Google Maps Javascript API. Consider changing your browser. Learn more Dismiss”


"Add location failed due to an internal error (import snapshot).

If this problem occurs again, please consult the Sketchup Knowledge Center for assistance."

Anyone else experiencing this? Can’t get it to work. I have a Sketchup Pro license.

Make sure Internet Explorer and Java Script are up to date.

Google Maps has been generating some of those error messages, though. It isn’t SketchUp but Google’s issue.

Because Google Maps have limited support to MSIE v 10 or higher.

Actually, it is caused by the SketchUp installers still setting the Browser Emulation attribute for “sketchup.exe” to v 9. (“Still” means since SketchUp stopped supporting XP installations which are limited to MSIE v 8.)

See this post:

But it has also been reported that setting emulation to v 11 will break the Dynamic Components webdialogs (because those dialogs are not yet using a <meta> tag to set compatibility mode and are using IE-specific non-W3C DOM functions.
:warning: NOTE: This Dynamic Components bug has since been fixed.

So, manually setting it to v 10 (0x2711) allows both DC webdialogs to work, and we no longer get the Google browser version warning on the “Add Location” page (from Google Maps.)

Wanna walk me through how i set the browser emulation to IE10 in windows 10 and Sketchup 2016?

It is not version specific. It is linked to any program named “sketchup.exe”.

Here is a zip archive with 4 .reg files for setting versions. (They likely require administrative priviliges to change the registry. Windows UAC may first prompt you for confirmation, or ask for an admin password if you are on a standard user account.) (1.5 KB)

Note: .reg files are by default associated with the regedit executable. When you double-click a .reg file, regedit will prompt you for confirmation to run the file and make changes to the registry. These files are plain text and can be viewed in any good code editor (of which plain-jane Notepad is not.)

DISCLAIMER: You take responsibility for changing the browser emulation setting. The Trimble SketchUp team is working on updates to Dynamic Components, etc. to try to work around the emulation issues. They may want it set to a specific setting when all the pieces fall into place later.

So consider any change you make temporary.

1 Like

Thanks, that got rid of the first error warning, But it still won´t import. :frowning:

Still get:

"Add location failed due to an internal error (import snapshot).

If this problem occurs again, please consult the Sketchup Knowledge Center for assistance."

Works OK for me for a US Florida location. Where are you trying to get terrain from ?

(Note: I’m on Win7.)

try if zooming 1 step out helps.

if not a plugin may interfere, try if disabling all plugins by “Window > Ruby Console”:


helps (restart SU after doing this).

enable plugs again by:


That worked…

Now to isolate the plugin f’#ing up… :frowning:

if you find it please post sothat others may benefit too, thx.

1 Like