Placemaker for SketchUp

googlemaps
browser_emulation
placemaker

#1

Bonjour, je vien d’installer l’outil Placemaker de sketchup (trial) mais ca fonctionne pas. lorsque je localise une région, ce message me surgit:
"You are using a browser that is not supported by the Google Maps JavaScript API. Consider changing your browser. "


#2

s’il vous plait, je suis pas développeur. j’ai mis à jour mon navigateur IE 11 et aussi google chrome mais rien ne marche.


#3

"You are using a browser that is not supported by the Google Maps JavaScript API. Consider changing your browser. " qu’est ce que ca veut dire. Merci


#4

I have asked someone on the Placemaker team to drop by, or to give me any suggestions that I could pass on.

Will let you know if I hear anything.


#5

@Whaat

This is due to pre-2017 versions of SketchUp installer setting the BROWSER_EMULATION registry attribute for “sketchup.exe” in the MSIE Feature Controls to IE version 9 emulation.

Google Maps no longer supports any IE version or emulation below v 10, and so is displaying this warning.

Temporarily you may be able to dismiss the warning and use the webdialog anyway,… but this may only be a temporary workaround that Google Maps may switch off.

There are two long term solutions:


(1) Set this registry attribute to IE v 11 emulation (as the SketchUp 2017 installers do.)


(2) … or for an extension (plugin) to use a meta tag in it’s html <head> element for the WebDialog.
[ This has been recommended for years ! ]

AND use a <!DOCTYPE> directive to prevent Quirks mode!

<meta http-equiv="x-ua-compatible" content="IE=11">

… or for just the latest version:

<meta http-equiv="x-ua-compatible" content="IE=edge">

See for reference:


#6

Thanks guys,

This user has since contacted us through email and we are working to resolve the problem with them.


#7

This topic was automatically closed after 91 days. New replies are no longer allowed.