Opening SketchUp Make 2017 opens Internet Explorer 11

msie
browser

#1

When I open SketchUp Make 2017, it also triggers an Internet Explorer 11 dialog box titled “Choose Home Page and Search Settings”. This box is difficult to remove as it has no method to close it. How is SketchUp tied to IE11 and how can I break this connection? I almost never use IE11 and then only on occasions where I have no other choice.


#2

SketchUp (and many extensions) use IE browser frames for UI dialog boxes and options interfaces, etc. It does not matter what your personal “default browser” is. (So make sure MSIE is up to date with all updates specifically for it from Windows Update.)

How long have you had SketchUp installed ?
Did you install it by right-clicking the installer, and choosing “Run as administrator” ?
Did you install any extra extensions yet (or does it only have those few that come with SketchUp) ?

It might help if you run MSIE once outside of SketchUp, and set your home page to “about:blank” (which is no home page, and just accept BING as the default search engine (or choose something like Google, or whatever.) Ie, just go through the initial setup once. Thereafter you need not use the standalone IE browser for anything. [I’m a Chrome user myself.]


#3

I would prefer not to, but I guess I will make sure IE is updated. I have had SketchUp since about 2015 and do not recall how it was initially installed, or how the latest version was installed. The issue only started about a month ago. I have no additional extensions installed.

I will try your suggestions and see if they help. Thank you.


#4

Find or re-download the installer, and right-click, choose “Run as administrator”, then choose the “Repair” option when the MS Installer asks you whether to repair or uninstall.


#5

Thank you.


#6

Thank yo. I have updated IE and the problem seems to have been corrected.

Paul Watson


#7

This topic was automatically closed after 91 days. New replies are no longer allowed.