SU 2015 Plugins menu missing


#1

Downloaded SU pro 2015. Plugins menu missing. Downloadid Visualizer and its not showing up.


#2

The Plugins menu is not visible until you install extensions that add their menus there. Also in SU2015 the name changed to “Extensions”.


#3

The plugins menu does not show up as long as there is no entry. It it had shown up and you clicked it, you would have come here and asked why the menu doesn’t open (or is empty).

Is quite clear. You are not supposed to copy-paste extensions. In many cases, they continue to work (often when they are pure Ruby extensions). But not in all cases. Visualizer is a binary extension, which needs an update for 2015 (and probably 64 bit).


#4

To all,

Still a tad confused on this one. Are you saying as soon as you load your Extensions a folder called “Extensions” will magically appear in the route tree in Windows Explorer of SU 2015…??

I downloaded SU 2015 Win64 & started organising the interface again with all the tool bars & also started to load in my extensions. Most loaded o.k. apart from VISUALIZER.

Anyway the strange thing is, although most of my extensions are loaded, I just can’t locate the Extensions (plugins) folder under SU 2015 main folder in Windows Explorer.

So where is it…??

I also decided to uninstall SU 2014 just a moment ago, I doubt SU 2015 shares any of these folders right.??

Over & out,
Clayton.


#5

The folder location is a different topic from the menu location.

The folder exists from the start directly after installing SketchUp. The folder is something users don’t need (anymore) to touch, because everything can be managed through the user interface in SketchUp (Window → Extension Warehouse, Preferences → Extensions).
Since SketchUp 2014, plugins are installed per user, which means the Plugins folder is located in your user directory. You can find it out by pasting into the Ruby Console: Sketchup.find_support_file('Plugins')


#6

Specific to Visualizer btw, there’s a new 2015 edition at https://getvisualizer.com/downloads (works with 2013/2014 too, but is best in 2015)


#7

Does anyone know if Trimble Scan Explorer Extension is SU 2015 compatible?


#8

Prior to 2013( ?) the plugin menu was activated by the examples ruby and was default as part of the SU install. After that the new file tree approach has it in the default install but was not brought into the user part of the file tree by default.


#9

Just to clear up some confusion. If you download a plugin not form the warehouse you need to drop it in the folder called “ShippedExtensions” formally “Plugins”. Just did it my self for “Pipe Along” and it worked. When you load Sketchup the toolbar now says “Extensions” not “Plugins”.


#10

That is not correct. “ShippedExtensions” is for our use. The location of the Plugins folder under SU2015 is by default:
C:\Users\YOUR USERNAME\AppData\Roaming\SketchUp\SketchUp 2015\SketchUp\Plugins

http://help.sketchup.com/en/article/38583
http://help.sketchup.com/en/article/3000050

But the recommended way to install is via Extension Warehouse or Preferences > Extensions > Install Extension.


#11

well the pugin that i needed was no longer avalible through the warehouse


#12

by the way it is currently working just fine in that folder


#13

Yes, it will load - but one shouldn’t be using it - it would be entirely unsupported. I’m not sure if that folder get wiped during updates. So please stick to the documented Plugins folder locations. I just wanted to make clear for anyone reading the thread what the correct and supported location is.


#14

FYI, the latest version of PipeAlongPath is a RBZ file, which will load in the proper location through Window > Preferences > Extension > Install extension button (follow prompts.) It is available through SketchUcation. SketchUcation also has it’s own plugin manager to simply plugin management for the plugins that site hosts.

But as plenty of plugins still comes as RB files, I make the AppData location a shortcut which can be quickly accessed for maintenance. Someone made a plugin to open that folder and there also is little Ruby code snippet to enter into the Ruby console.


#15

I am using SketchUP Make 2015 in Windows 7 64 bit along with Vue Studio 2014.

I bought a plugin/extension from Cornucopia 3D that exports Sketchup models in the VOB format to be used in Vue. It is a Ruby rbz file. I am having problems getting it installed and working. I have looked and there is no C:\Users\YOUR USERNAME\AppData\Roaming\SketchUp\SketchUp 2015\SketchUp\Plugins
on my computer. I find the C:\Users\John\ but there is no AppData\Roaming etc. The only Sketchup 2015 folder that I can find is under programs. Do I install it in ShippedExtensions folder? Any help appreciated.


#16

If you have an RBZ file for any plugin/extension [which is the handy archive format for all plugins/extensions for the last several years - at least since v8M2], then they are installed using the SketchUp native Preferences > Extensions > Install… button.
Its contents are automatically extracted, installed into the correct location[s] and loaded - typically in the user’s Plugins folder [which in all recent versions is located in the path …/Roaming/… - and which is also ‘hidden’ unless you elect for them to be visible in Folder-Options - although you’ll never normally need to look in it anyway…]
Occasionally you might need to restart SketchUp to effect all of the changes, but thereafter the newly installed tool becomes available whenever SketchUp is started…


#17

Thanks for your reply. I am still having a problem. When I tried to
install using preferences > Extensions > install as you suggested I
found that it is an RBS file rather than RBZ. The file is called
VueExport.rbs The install is only looking for RBZ files. What do I do?

John


#18

OK. I made the hidden files visible and found the path C:\Users\YOUR
USERNAME\AppData\Roaming\SketchUp\SketchUp 2015\SketchUp\Plugins. I
did look in local, but Sketchup was only listed in Roaming. I coped the
files into the Plugins directory and restarted Sketchup 2015 and the Vue
exporter is now there. Thanks for your help! I had no idea that those
files were hidden!

John


#20

@Ornithophilia, RTFM.

you having an issue with following instructions, does not make the instructions invalid…

install vRay properly and you may have better luck…

john


#21

I did, ALL IT SAID WAS TO TELL IT WHERE SKETCHUP WAS INSTALLED AND THEN IT INSTALLED IT AND SAID IT WAS FINISHED!!!