Accessing installed plugins

I have several plugins installed and shown as active in the extension manager but I cannnot access them from the toolbar???

What plugins are they? Maybe they don’t have toolbars to access. Or maybe they don’t show up in the menu you’re looking in.

Depends on the plugin.

Some don’t have a toolbar, or don’t have it turned on by default.

Some show in a menu other than Extensions.

Some only have a Context menu, and need to have an object selected then a R-click to show their action(s).

As DaveR says, what plugins are they?

These extensions were accessible in the main toolbar until I had to reinstall Windows on my PC. The Ruby files are still there and installed with the sketchup extension manager but, unlike in the past, I cannot find them anywhere in Sketchup…

Is there some reason you are keeping these extensions a secret? If you want help sorting this out you need to tell us which ones they are.

No secret at all, but the extension I have loaded are from a french editor and not from the extension warehouse… I could send you the rbz file if you want (how can I do that?)
Thanks for your assistance!

You could upload the .rbz files here.

Probably a silly question, but have you restarted SU since you reinstalled the extension(s)?

And what ‘toolbar’ did it/they used to show in?

Have you checked in View/Toolbars to see if there is a toolbar that isn’t turned on which might be the one you are looking for?

Here is one of these plugins:
._bouvetage-2.0.rbz (4 KB)

That file doesn’t appear to be complete.

Ibouvetage-2.0.rbz (150.8 KB) may have sent you a bad version; try this one!

That one works.

When I install it in Make 2017 (in English) , it shows as Tongue assembly in the Draw menu. And I didn’t have to restart SU.

It doesn’t appear to have a toolbar at all.

Thanks John, I have indeed found it in the Draw menu! Before I reinstalled Windows, this extension appeared as an icon in my tool bar and that is where I was hoping to find it…

By the way, please update your profile to show the Windows version, and your graphics card - ‘cc’ isn’t a graphics card.

That will help others to help you better in future.

1 Like

Looking at the website from which it comes, it would appear that it would be included in a toolbar from another extension.

Maybe you should make sure you have the entire set of extensions from the author.

Interesting that you need a plugin to do that.

I put"cc" for the graphics card because I do not know where to find the name of the one I have…

Well, I don’t fully understand that. What toolbar did it appear in? It doesn’t appear to have one of its own - at least, nothing like it shows when (on Mac) I look at View/Tool palettes.
image

Did you add a shortcut to it somehow and add it to a customizable toolbar?

Maybe, if you added other plugins from the same source, they add a toolbar for this one?

PS. I tried restarting SU before checking again if it has its own toolbar. It still doesn’t show - see image above, taken after restarting SU.

Looking at the plugin file itself, there is no toolbar associated with it. To get a toolbar button for it you need the parent extension.

My spoken French isn’t good enough to understand the explanation of what the plugin(s) do, except that this one seems to be for making loose tenons (in English), including the proprietary Festool Domino ones.

Is that about right?

To find more about your graphics card, look for example at

or just google for “how to find graphics card details windows”

Thanks John for your help! Yes this plugin and a few others from the same editor are about joining.
As for my graphics card, I now have included a correct reference (Intel® HD Graphics Family)
in my profile.
Have a great day!