Where did my extensions/plugins go?

I just installed a number of extensions (Fredo Tools, Solid Inspector^2, Fredo Corner, Bezier spline, …) on my new install of SU 2019. These did actually install and floating menu bars appeared. I closed the menu bars, closed SU, restarted sketchup and there is no sign of these extensions. No menu items have any of these as a choice, the toolbars are not available under View-Toolbars. There is no plug-ins or extensions menu item in the top menu bar as there was in SU 2014. On the other hand, if I select Window->Extension Manager the plug-ins are all listed as installed. I disabled a number of these and restarted, but they appeared enabled on the restart. I uninstalled a number of these (Solid Inspector^2, Bezier spline) and the problem persists.

I tried starting sketchup using “run as admin” - no difference.

I reinstalled one of the deleted extensions and all the “missing” extensions appeared - both as toolbars and menu items. I left the menus open and closed SU, then re-opened. Everything is gone again.

What do I try next?

When you installed 2019 did you right click the installer file and run as administrator? If you didn’t I’d start there first. Right click the installer file and select run as administrator. When prompted choose repair and let the installer run again. That’s the correct way to install SketchUp, installing by wrongly double clicking the installer can cause all sorts of weird problems. Just like yours.

As @IanT explains - on Windows, if you haven’t installed SketchUp by selecting its installer’s exe file [usually in Downloads] and choosing the right-click > context-menu item “Run as administrator”, then all kinds of unpredictable weird problems can happen - often about folder/file permissions where the user/SketchUp can not save preferences, toolbar settings etc as it closes.
Using “Run as administrator” ensures the Installation is done properly.
If it’s already installed choose the “Repair” option when offered.
Any customizations you have made should be retained.

When doing a Repair ensure that SketchUp is closed and that you are logged in as your normal Windows user-account [never use the special administrator account, BUT if your normal user has some admin-powers that is OK].
Also never ‘run’ SketchUp itself as the administrator - this can mask the affects of an incorrect installation, BUT it has its own knock-on affects like blocking drag-and-drop, because then SketchUp is running at an elevated level above Windows Explorer, and a lower level app can’t affect a higher level app.

Never ‘Run’ any Windows installer’s exe file by double-clicking on its icon.
Even if your user-account has some admin-powers it is NOT the same thing as doing it properly as outlined above - otherwise unpredictable weirdness will surely follow…

PS: Occasionally some custom extension settings files get locked with the wrong permissions from the initial ‘wrong’ installation - e.g. some of Fredo’s - so if you have fixed ‘most’ things, but still get problems please come back and some one will advise which of the problem files to delete so they get remade ‘properly’ !

I tried repair, then I uninstalled, deleted the AppData Sketchup 2019 directory and reinstalled via right click on the installer file. No joy.
I’m baffled by this statement by TIG

I’ve been running Win 7 since it came out about 10 years ago and have NEVER installed programs this way - I’ve always just double clicked installers and have had no problems (my standard user account has admin priv). I’ve installed many, many programs this way (control panel ->programs and features list 334 programs installed, so I really do mean many).

With almost all newer app’s of any complexity [SketchUp being one], on Windows if you don’t install it using “Run as administrator” it is a well know cause of unpredictable permissions and other weird issues. Even if your usual account has some admin-powers it is NOT the sam thing to “Run” it.
Perhaps thus far Win7 has been forgiving enough to let you install ‘the wrong way’.
But you could always try doing it properly - there is usually no need to uninstall first, just choose “Repair” when it’s offered…
However, Fredo’s tools does write a special data file to remember settings across settings etc, and if your permissions are really messed up, then you will get error messages because the file is inaccessible - if that happens we can advise on which file to delete to fix that related issue… ask if that happens…

Since Win7 loses all MS support in a few months time you should perhaps consider upgrading your system.
Any new Win version will expect you to install things properly…

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.