Get Visualizer working on SketchUp 2016


#1

I have Visualizer in SketchUp 2015, but this extension doesn’t support the newer versions (2016).
I’ve done a little research and I found out you have to copy 2 items (ImaginationVisualizer and ImaginationVisualizer.rb) from the SketchUp 2015 folder to the SketchUp 2016 folder in a folder called Plugins, which you have to create if it doesn’t exist already.
I have already done that (copied the 2 files to the newer version’s folder) and by doing that you should be able to use Visualizer in SU 2016, but when I open SU 2016, Visualizer doesn’t appear anywhere, not even in Window / Preferences / Extensions.

Any solution?

Thanks in advance.


#2

This is untrue. On Windows editions, the SketchUp “Plugins” folder was moved into the User’s %AppData% folder hierarchy, with the SketchUp 2014 release.

Prior to this, (SketchUp 2013 and older,) had the “Plugins” folder as a sub-folder of the SketchUp program folder. This caused folder access permissions issues for many users.

Some extensions use external installers that can install into a SketchUp “Plugins” folder in the %ProgramData% folder hierarchy, which all user accounts (on a single workstation) can read, but may still have write permission problems for users.


In SketchUp 2016+, if an extension is unsigned, you will need to reduce the Extension Load Policy to either “prompt” or “ignore”.


#3

You’re right. I’ve found these files where you say, but all the users from the forums I read about this found their files in the SketchUp 2015 folder, and that’s why I decided to say I found them in the same place “everyone” did to avoid problems. The thing is I got these files copied, but visualizer doesn’t appear anywhere.
Thank you for your response.


#4

Again, SketchUp 2016 and higher has extension signing, and a Extension Load Policy. Visualizer came out prior to this. You will need to relax this policy setting, in order to even “check the box” to switch Visualizer on.


#5

I have already marked the Unrestricted option to this policy, but Visualizer doesn’t appear in the extension box.


#6

Did you restart SketchUp ?


#7

Yes. I already had the Unrestricted option marked way before this problem.


#8

Oripux,
I wanted to participate in this discussion, but I’m in the same situation as you. I have the Sketchup 2016 make, win 64bits version, but I can not install the Visualizer plugin;). Sorry for Google English