SU 2014 Add Location/Geo-locate hangs, doesn't import/work properly


#1

Version: SU Pro 2014 (license not applied yet, fresh install, transferring license from old computer)
OS: Mac OS X 10.7.5
Behavior: I click add location, the map comes up and it looks normal except the zoom bar is missing. I search for a location, select the area, and hit grab. The window hangs forever until I ‘x’ out of it which doesn’t import anything obviously.

I know this is well-worn territory but I can’t seem to find a good answer for this in any forum I can access. I’ve solved this same issue before in SU 8 when the Google/Trimble crossover happened but that forum now seems to be inaccessible (says I need to be a member to access but there’s no way to request membership). I remember changing a line of code referencing the GMaps address or something but it was a while ago. Hoping someone can steer me in the right direction and really hoping the answer isn’t “you need to upgrade to 2015, we don’t troubleshoot 2014 anymore”. Any help is appreciated! Thanks!


#2

See this topic:


Also see this article at the SketchUp Sage Site:
Why can’t SketchUp access the 3D Warehouse or Extension Warehouse or Add Location?


#3

Thanks for the reply! I saw this post as response to several other issues in the forum so it was one of the first things I tried originally. I tried it again just now and the Add Location function is still not working (still hangs) though now it has one new quirk to it. When I search for a place, the white square locates on the map to the specified search location but the zoom level does not change at all like it used to (or rather does during proper operation), it stays on the most zoomed out view of the world. So still no luck. Again any help is super appreciated!


#4

I am having the same problem with no solutions being provided by sketch up. this is such a critically helpful tool that I can’t believe the problem even exists. where is tech support when you need them?


#5

Bump?

Anyone from Sketchup able to help please?