SU 20024 Keeps Crashing 2023 MBP Max

@Elmtec-Adam @colin

While streaming data on the console and looking at the window server, I noticed these.

default	14:13:15.023833-0600	WindowServer	Process now frontmost: <private>
default	14:13:15.041415-0600	WindowServer	<private> adding window 12719 with state "none"; now 20 window(s) exist.
default	14:13:15.041440-0600	WindowServer	<private> updated window 12719 from "none" to "hidden".
error	14:13:15.062026-0600	WindowServer	: Operation on a window 0x31af requiring rights <private> by caller <private> (SystemOwner)
error	14:13:15.065970-0600	WindowServer	Clearing datagram buffer for cid 0x50173. Client state: Data count: 16396 connectionIsUnresponsive: 0 clientMayIgnoreEvents: 1 clientIsSuspended: 0
error	14:13:15.096959-0600	WindowServer	Clearing datagram buffer for cid 0xfe643. Client state: Data count: 16388 connectionIsUnresponsive: 0 clientMayIgnoreEvents: 1 clientIsSuspended: 0
default	14:13:15.099080-0600	WindowServer	<private> updated window 12719 from "hidden" to "visible".
default	14:13:15.099093-0600	WindowServer	<private> overall window state is now "visible"

Pardon me if this is not related but console streaming is very quick. I can try to filter a little or see if I can tail directly on the log file somehow.

@Elmtec-Adam Just to clarify, I can try to figure out the cable itself, but the only application that sufferes from this process is Sketchup Version 24, Not version 23 or other applications. Could this have anything to do with the graphics engine in version 24?

Pluggable USBC-DP
Link :point_up_2:

Thanks.
My experience with alt mode adapters etc has always been that they come with some caveats. Looking at documentation for the common ones , Apple have changed a number of things about how they work in recent updates.

If you have a look at the UI on the display itself, can you see what it is reporting as the resolution being sent?

I ordered one of those, and should be able to do tests on Wednesday.

One thing for you to try, do you still get the symptoms if you change Settings, Graphics, to use the Classic graphics engine?

Colin, the short answer is that I can eliminate the problem in classic graphics and re-duplicate the problem with the new graphics engine.

More details:
Last night I changed the settings but I didn’t know how settings were applied because modals were invisible in the black section of the screen. Today, when I went reading though the logs, I found things related to init processes so I figured I’d try making changes and fully closing the app, no messing with cache or hardware. Anyway, I discovered that when the project window is closed but Sketchup is still focused up in the menu bar, I can invoke the settings window pane and change the graphics mode without video issues. So this time I received two modals simultaneously when I changed to the classic graphics.

I quit the app and restarted and something initialized correctly, no problem. Toggle back to new graphics engine, quit, re-launch app, boom, problem. I also tried messing with the multi-sample settings but no dice. The graphics engine setting itself seems to be the issue.

How can I help your engineers get a better picture of my hardware or configuration to ‘potentially’ prioritize a bug? BTW, I’m not expecting this is squashed right now. I understand the SDLC. It just helps to have a complete picture when some enginer is trying to figure out what actually happened.

@Dominick I am sorry for hijacking your thread but this was the absolute closest thing I could find to my issue. You have a better chipset, otherwise similar system to mine. I hope this helps you too.

There is an oddity with M1, and M2 and 3 I imagine, where having Use fast feedback turned on will clash with the antialiasing settings that the classic graphics engine uses. In one pass you were trying to change from the new graphics engine to the classic one, with Use fast feedback, and with antialiasing probably set to 2x or higher. So, one dialog was telling you the change you had made would take effect for new windows, and the other was telling you that SketchUp had altered the settings to prevent the clash between Use fast feedback and the antialiasing settings.

You could uncheck the Use fast feedback box, and then you can have antialiasing settings higher than 0x. You also could try the new graphics engine with antialiasing set to 0x. If doing that makes SketchUp work without all of the screen flashing, then your issue really is the same as Dominick’s.

I finally generated a crash. I actually have the text from the apple crash reporting utility and additionally the text from the bug splat report. I think there’s some overlap, but this time it’s a sig abort due to a bad address when initializing open GL. Although this is a different symptom, this was encountered while launching the app because of my intent to play with the checkboxes from your input regarding feedback and anti-aliasing. I was trying to play with the selection for 0x - 4x last night, but I’ll try again to make sure that I did it right, like your suggestion.

No worries Dan. I am following the progression of the items discussed. I settled on working in full 4k all the time and no issues anymore.

1 Like

Interesting. I wasn’t using the 4k for the same reason as you. I’ll verify behavior in 4k too, thank you.

I just tried it again at 3360x1890 and it starts to black out… If I don’t shrink the window right away it force restarts my laptop. 4k works perfectly other than squinting to read the menus.

I was thinking I had 4K monitors, but they’re all 2560x1440 (whatever you call that). Hopefully that’s not problematic.

I think I figured out the trigger to make Sketchup behave oddly. I noticed that when I open a new template, it opens on the default monitor at ‘nearly’ full-screen, but not quite (this would be the laptop display). When I pull the window over to my external monitor, Sketchup resizes the the window.

I did test the checkboxes and antialias settings to verify, but the same results as last night: they have no effect. Changing between classic and new graphics engine allows the problem to be found.

In the video that I posted above, you can see the display issue that falsely appears like a monitor or cable issue. When I reverted to classic graphics engine, I was noticing the window was redrawn at a lager size and so I enabled the new graphics engine and moved the window to my external monitor and the display had issues. I moved the window back to the laptop, resized the window to be maybe only 1/4 of the display size. I pulled that over to the external display and the blinking never happened.

Preconditions:
Have sketchup in new graphics mode.
Have your account logged in/cached logged in.
Have the sketchup window open on the primary display at almost the full display size.

Duplicate:
Open sketchup.
Create a new file from a template (woodworking inches, in my case)
Pull the window over to the external monitor.
Result: Video failure.

2nd time.
Open Sketch up.
Create a new a new file from a template (woodworking inches, in my case)
reduce the window’s size to only 1/4 of the primary display size.
Pull the app window over to the external monitor.
Result: No video failure.

Not a solution to your problem , but totally related and it explains the weird low resolutions.

I’ve been doin a Bit of reading up on this and have stumbled across some interesting reading - apple hobble hidpi displays that aren’t Apple sanctioned - so they render at a lower res rather than full resolution and over sampling.
This actually explains a lot about why my monitor always looked inexplicably crappy.
There is a piece of software you can use to curcumvent this and make everything look better.

I’m going to give this a try tommorow on my Mac setup

@Elmtec-Adam, this was interesting. I knew that Apple did some fluffy magic on the display behavior but it’s been a long while since I have given it any thought. I was happy to see the GitHub link but a little bummed this project wasn’t open source. I was hoping to read some of the implementation details. Thank you again.

Dan

There is an option in Displays for setting what pixel size, and what quality you want. Changing between normal and low resolution is noticeable. Here are the resolutions for my 4k Samsung TV:

@colin How do we get issue tracking on this? Not that it needs to be immediately fixed, but here is the logic.

No other apps have this issue. Version 23 doesn’t have the issue. Version 24 does, which is the introduction of the graphics engine. I’ve been able to verify that using the new graphics engine in v24 along with sketchup’s behavior to slightly resize up when moving to the external monitor is where the wheels come off. Since this is a bug as a direct result of a new feature brought to users, this is not working as designed. It would be cool to get this fixed for others in the future.

The timing happens to be good. I have what I need to test tomorrow, and the developer most likely to have ideas about the problem will be in. And he will have his M3 MacBook Pro with him. I may take my M3 MacBook Pro in as well. There are other colleagues who have M2 Macs if the problem doesn’t happen for us on M3.

There isn’t tracking as such, but I will let you know if/when we have reproduced the problem, and when we have figured out a fix for it.

I appreciate it. If there is any mystery as to duplicating the issue, I’m willing to run debug builds, etc… to help your devs. I am a dev myself, but I’m willing to just follow directions if that’s needed.

Heads up, Somebody on a 2017 MB Air was having a crash issue with v24 and not v23. The idea was a little common sense based on the explanation, but asking the person to revert to the classic engine solved the issue there too. Point is that the impact is wider and not necessarily an apple silicon issue.

Classic graphics for 2017 MB Air and Sketchup v24

Hang in there. This will probably be worth it after a few revisions!!